Spandsp installation with RPM install of Asterisk

Is it possible to install spandsp for Fax use when the asterisk installation is via RPM?

Does anyone have a method to do this?

Many thanks

Any Ideas how RPM installers can get spandsp installed so I can use the fax features on asterisk 13 and later?


If you installed correctly the Asterisk packages a yum install spandsp will install all the dependencies or at least tell you what do you need/confilct with the installation.

Reading the documentation for installing do I not need to recompile?

Which repo should I target to pull in spandsp ?

Thanks for the reply.

You recompile when you install from sources, using RPMS the system will look all the dependencies including the compatible asterisk versions.

About the Repo I dont use rpms to install asterisk so i dont know, but take a look on rpmforge maybe that have it.

Hmmm I can’t find an RPM in any of the repo’s i usually use centos, epel, asterisk it doesn’t look like there is generally one around.

Can you mix? i think this comes back to my origial question. Can you install spandsp from source and use it with asterisk installed via RPM?

If you install from source do you have to do anything to asterisk?


So if I do a bit more poking about and perhaps the correct way is just to install spandsp from source and make sure the modules are loaded.

Has anyone had any success with this method?

OK so I ran up a test.

Installed with RPM’s
Checked that fax services are loaded (I think)
installed spandsp from source
added relevant config to dialplan

and ran a test

and this is the error message I get

Any ideas why this is failing?

I think you should start over and do all from sources… And maybe later create RPMS from that installation.

wasn’t planning on going that far and might not fix the problem or may introduce more.

What are the dependencies required for faxing on asterisk 13?
How do I test all the required modules are loaded?
What troubleshooting fax tips are there?

I’m using ReceiveFax in my dialplan is this right?

So here is problem 1

CLI> module show like Module Description Use Count Status Support Level 0 modules loaded

I have tried installing from source over the top of my RPM install. All works although there are some complaints about some of the modules being created by older versions of asterisk.

I’m not planning on making this my default method of install but may grab the and manually copy it into the modules directory of a test server which is all I think some of the asterisk rpm’s do anyway.

Does this sound like it will work?

The actual RPMs will just copy files into various directories, but they will have been written on the assumption that all the files were compiled in the same environment, and at the same time. If you can match the environment, you can build the whole of Asterisk, then just copy the individual modules, but that will only work if the original options enable any optional features needed by the new modules.

However, if you build everything, installing everything from the build, rather than the package, will ensure that everything is compatible.

You basically are not going to get a lot of support for mixing packages and compiled code, because so few people attempt it.

I think you are right. I have been using yum to keep everything up to date but I think I am going to have to give this up and go with building from source.

One question. I like to automate my builds, it ensures consistency which makes things a lot easier to support.

how can I auto mate the building of asterisk when I need to go into make menuselect to select the modules I need?

menuselect stores the last set of settings in a file. I think that is menuselect.makeopts. If you leave the build tree open, or you copy that file across, you don’t need to re-run menuselect.

Great that sounds like a workable solution. I’ll have a look at how much work it is to convert over from using RPM’s I think not much and I can just write a good install script which will do the job the RPM was doing.

I suppose the only draw back is I will have to install more libraries so I can compile.

Hmm bit off topic now but how do you update? Install over the top or de-install and install new?