[Solved] Previously fine system now won't start

Well solved may be too strong a word. The G729 codec is what caused the issue. I’ve changed nothing and all of a sudden it core dumps. I stopped loading it as I had never gotten it implemented yet and everything is fine again.


My Asterisk server of 2 years has decided to not come up. Here is what information I have gathered so far and if anyone has come across this issue I’d appreciate any and all help. Thanks in advance.

Results of safe_asterisk

[root@voip root]# safe_asterisk -vvvvvvvvvvvvvvvv
[root@voip root]# /usr/sbin/safe_asterisk: line 77: 1193 Illegal instruction (core dumped) asterisk ${ASTARGS} 1>&/dev/${TTY} </dev/${TTY}
Asterisk ended with exit status 132
Asterisk exited on signal 4.
Automatically restarting Asterisk.
Asterisk ended with exit status 1
Asterisk died with code 1. Aborting.

Asterisk version is 1.0

I have 2 X101P clones and one real X101P boards in the PBX and they have worked fine. As a matter of fact zttool shows that everything is still fine with the boards.

As I stated to start with, this system had ran flawlessly for 2 years and I’ve changed nothing on the system. It sits in the closet doing its thing day in and day out

How do you disable loading the codec?
I have the same issue.

tks