Asterisk broken after registering G729 codec


#1

After registering my G729 codec, Asterisk cannot be restarted, message is:
[root@asterisk1 ~]# asterisk -r
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)

This is the second time it happens, the first time on an SME 6.5RC1 system (RH7), the second time on latest asterisk@Home vs 1.2 on Centos 4.2. In both cases, the server was a standard box with SCISI drive.

I have checked the existence of the file /var/run/asterisk/asterisk.ctl, and it is present.
[root@asterisk1 asterisk]# ls /var/run/asterisk/
asterisk.ctl asterisk.pid

However, the file asterisk.ctl is highlighted red. When checking the same file with MC, the file is highlighted in black and has an equal sign in front , i.e. =asterisk.ctl

Have searched forum, no answers that I can find.
Some help would be very appreciated
chris


#2

Try posting a message to tech support at Digium, they reply sometimes.

rgds


#3

Thanks Middletn,

Since posting, I found this in the FAQ:
Q. I installed G.729 and now asterisk will not start, what’s wrong?
A. Asterisk must now be loaded in the foreground using the “c” option when starting asterisk. Running “safe_asterisk” should load asterisk into the background. Another solution is to run asterisk using the program screen. Asterisk may need to be started from the directory that you ran the Registration program from also.

Not sure how to deal with this information, somewhat cryptic for a begineer…
Regards


#4

Problem solved. My server is an old dual processor 180MMX + SCISI. The link supplied in Digium Howto fetches a codec optimized for a PIV … :blush: Removing this codec from /usr/lib/astersik/modules and rebooting fixes things - * is back on line. I will try a codec designed for 386 and see.

Hope this helps someone - I feel better already!
regards
chris