[SOLVED] Issue with voicemail languages in v1.2?


#1

I have installed a language sound pack for Spanish on my Asterisk v1.2 server, in case case Spanish. I have dropped everything into this directory:

/var/lib/asterisk/lib/sounds

For the most part it works fine when I set this variable for certain users before calling the VoicemailMain app:

I only seem to have a problem when I attempt to access a voicemail box to play a message back. When I do this, I get:

[quote=“CLI”]Nov 18 16:19:50 WARNING[5104]: file.c:508 ast_openstream_full: File digits/1M does not exist in any format
Nov 18 16:19:50 WARNING[5104]: file.c:820 ast_streamfile: Unable to open digits/1M (format alaw): No such file or directory[/quote]

The 1M.gsm does exist in /var/lib/asterisk/sounds/es/digits but does not exist in /var/lib/asterisk/sounds/digits (the English set). Why is voicemail, even though the language is set to ‘es’ attempting to go to the base/English file set (as it apparently is) and yet work fine for the rest of the voicemail system?

A bug?


#2

Figured out how to fix the issue, created a symbolic link in:

/var/lib/asterisk/sounds/digits

as:

lrwxrwxrwx 1 root root 13 Nov 18 16:37 es -> …/es/digits/

Strange that it picks up all of the other files from /var/lib/asterisk/sounds/es, but not the digits. Anyway, works now.

And of course, it is described this way in the Wiki:

voip-info.org/wiki/view/Aste … ernational

So my bad…


#3

i just downloaded and listened to the “southern england” offering on that page … how did they get Jade to do it ? :stuck_out_tongue: