SOLVED: incoming call to a pri managed with asterisk


#1

hi all in the forum.
i don’t know how to solve this problem so i post here for some support. thanks for anyone kind of help me!

i setup in the incoming pri context i have this extension:

exten => _012345XXX,…

where 012345 is my root number and i have XXX cipher avaible from my pri. go through selection

the problem is:
for almost 80% of the call people still able to call 012345XXX but the other 20% in the log of my pbx i saw that try yo call 012345 extension not found. but they sait that are calling 012345XXX and not 012345. seems that there is something that cut the last 3 cipher.or dont permit to see after the root number.
is there some mod that i can do in chan dahdi or in astersik??? maybe set some slow waiting for the number or something like that. anyone have experienced this problem?
using asterisk 1.8.6.0 and dahdi 2.5.0
as interface i’m using a xorcom pri with HWEC
the pri is a E1 line

i try to call my pri with my landline external phone and i wasnt able to reproduce the problem but in my log i saw like:
[Nov 21 17:23:53] VERBOSE[30283] sig_pri.c: – Accepting call from ‘xxxxxxxx’ to ‘012345’ on channel 0/6, span 1
(is accepting cause i configure the exten 012345 cause ifnot some people werent able to call my company at all)

thanks and let me know


#2

i try to be more precise:
my chan_dahdi:

[channels] faxdetect=no busydetect=yes threewaycalling=yes cancallforward=yes echocancel=yes echocancelwhenbridged=yes echotraining=no switchtype=euroisdn callerid=asreceived relaxdtmf=yes signalling = pri_cpe context = from-pstn group=1 channel => 1-15,17-31
my extension.conf

[from-pstn] exten => 12345XXX,1,....
the root number is 12345
why people arent able to call 12345XXX and they are stopped in the root number. they said they call the the complete extension number but asterisk said:

is there something i can do for that?
is not a misconfiguration cause in almost all the case is working. only in some case happened.
is there some pri conf in chan_dahdi? or in asterisk in general?

:question: :question: :question: :question: :question:


#3

i was wondering if the incoming go trough selection may be blocked for some of the 30 channel of my pri. while the other are still ok some channel my be misconfigured.

i want to do some tries but i don’t know how to do.
is there a way for an incoming well know external call made by an external phoneline (my test) and redirect it into a specific pri channel number. doing this 30 times to test the channel one by one and observe if in asterisk the called number is the root (12345) or the complete 12345XXX.

any idea?
:question: :question: :question: :question: :question:


#4

i test all the 30 pri line with a mobile. i roundrobin my 30 lines doing incoming call and all goes trough the correct number
12345XXX and not 12345.
now i was thinking about some incompatibilities with some type of old analog phones or old faxes that trying to call my pri lines they stopped at 12345 and goes not throug the 12345XXX correct selection.

may be???
someone is understand what im saying or im too cryptic or my english is horribile???

thanks


#5

Try turning “overlapdial” on for incoming calls (“incoming” or “both” (“yes” or “true” might work, as well as “both”)). (I suspect that all your problem calls are not from mobiles.)


#6

true. no call from mobile have this problem. is something related to analog phone? i got a lot of incoming call from fax machine trying to reach 12345XXX and the stopped at 12345.

i set overlapdial=yes in chan_dahdi.conf
core restart now from console

now i only have to wait cause i’m not able to reproduce the problem :cry: :cry: :cry:

you suspect something david55?


#7

With mobile networks, the number is always completely keyed before any attempt is made to start the call. With other networks, the network may start the outgoing call as soon as it has enough digits to route it itself, but before the complete number has arrived.


#8

with this options everything seems working well! ty david55