[Solved] HPEC installation error - can't compile zaptel

I upgraded my AAH2.7 pbx to asterisk 1.2.17, zaptel 1.2.16, most recent libpri, addons today with freepbx2.2.0. I then confirmed that I could make pstn calls (TDM400) and voip calls ok.

Then I tried to install the HPEC following the directions given with license.
When I try to recompile zaptel, I get this error

[code][root@asterisk1 hpec]# cd …
[root@asterisk1 zaptel-1.2.16]# make

make -C /lib/modules/2.6.9-42.0.10.EL/build SUBDIRS=/usr/src/zaptel-1.2.16 HOTPL UG_FIRMWARE=yes

make[1]: Entering directory `/usr/src/kernels/2.6.9-42.0.10.EL-i686’
Compile xpp (version trunk-r3495)

Building modules, stage 2.
Warning: could not find /usr/src/zaptel-1.2.16/hpec/.hpec_x86_32.o.cmd for /usr/

make[1]: Leaving directory `/usr/src/kernels/2.6.9-42.0.10.EL-i686’
[root@asterisk1 zaptel-1.2.16]# cd hpec
[root@asterisk1 hpec]#
[root@asterisk1 hpec]# tar -zxvf hpec-8.20-i686.tar.gz
[root@asterisk1 hpec]# dir
hpec-8.20-i686.tar.gz hpec.h hpec_user.h hpec_x86_32.o hpec_x86_32.o_shipped hpec_zaptel.h LICENSE
[root@asterisk1 hpec]#[/code]

If I run a make clean, then make install, zaptel does compile.
I run modprobe zaptel which runs but no info about hpec.

When I run
I get message that zaptel was not built with HPEC.
The error looks like I am missing a file. I appreciate your help.

System specs:
Dell dimension 3000. Pentium 4 2.8 ghz. Dedicated machine.
Kernel 2.6.9-42.0.10.EL on an i686. CenOS release 4.2 (Final)
TDM400 card with 4fxo. 1 gb ram.

On my Centos 4.4 system, I had to first make sure no Zaptel modules were loaded, before I did the “make install”. An easy way to do this is to remove the boot startup with “chkconfig zaptel off” or similar, reboot and then follow the instructions by untaring the HPEC files in the hpec subdirectory, just as you show. Do a “make”, and “make install”. Also, do a “make config” if you need to update the startup script in /etc/rc.d/init.d.

Startup zaptel with service zaptel start. Then run zaphpec_enable and it should respond correctly. This worked for me. Last night, I tried to use the new Zaptel-1.4.1 and hpec. It compiled OK, installed, but no audio on my Zap line. Go figure. So back to zaptel-1.2.15. It should not be so difficult, but I assume it is some module incompatibility issue.

As an aside, I also tested Octasic’s new soft echo product. It is same cost as hpec, but in my case, installed easily, for 1.4.0 and works well. I have not compared CPU requirements, but both use a good bit of the cpu, of course depending on number of channels. Good look.

Do “make distclean” first.

Thank you both for your replies.
I’ll give it another go.

I have not heard of make distclean before?!?!?

compiling zaptel definitely went smoothly this time. I still can’t get hpec to compile with zaptel.

[code][root@asterisk1 zaptel-1.2.16]# genzaptelconf


Generating '/etc/zaptel.conf’
Generating '/etc/asterisk/zapata-auto.conf’
Unloading zaptel hardware drivers: wctdm24xxp wctdm wcfxo wcte11xp wct1xxp wct4xxp tor2.
Removing zaptel module: [ OK ]
Loading zaptel framework: [ OK ]
Waiting for zap to come online…OK
Loading zaptel hardware modules: wctdm wctdm24xxpRunning zt[ OK ]

Permissions OK

Asterisk Started

FOP Server Started
Chan Extension Context Language MusicOnHold
pseudo from-pstn en
1 from-pstn en
2 from-pstn en
3 from-pstn en
4 from-pstn en
Verbosity is at least 3
[root@asterisk1 zaptel-1.2.16]# cd /root
[root@asterisk1 ~]# ./zaphpec_enable
Digium High-Performance Echo Canceller Enabler
Copyright © 2006, Digium, Inc.
Version 1.0.1
Use the ‘-l’ option to see license information for software
included in this program.

Found key ‘HPEC-PSAMSFLYYM6P’ for 4 channels.
Found valid HPEC licenses for 4 channels.
The Zaptel module on this system appears to have been built without
HPEC support. Please check your Zaptel build.
[root@asterisk1 ~]#[/code]

It looks like hpec is in the right place.

[root@asterisk1 zaptel-1.2.16]# cd hpec [root@asterisk1 hpec]# dir hpec-8.20-i686.tar.gz hpec_user.h hpec_x86_32.o_shipped LICENSE hpec.h hpec_x86_32.o hpec_zaptel.h

Did you do a ‘make distclean’ in the zaptel source first?

Just wondering if anyone has gotten this to work? I’m having the same problem. I’m running TrixBox 2.0.


i’ve been told this may be an erroneous message and just to reboot and see hpec load during boot up. haven’t tried it yet. will post my results later. if not, i’ll call digium.

Make sure to run the enabler script after your reboot.

yep. you all are correct. So here is my outline that gave me no errors. Only thing is. After I reboot my machine, lets say tomorrow, how will I know HPEC is still running. I don’t see any confirmation of this or know any command to check status of echo cancel.

Here is what I did for pentium 4 desktop processor (be careful as some of the longer lines are split and they need to be ONE line):

chkconfig zaptel off shutdown -r now amportal stop cd /usr/src wget http://ftp.digium.com/pub/telephony/zaptel/zaptel-1.2.16.tar.gz tar -zxvf zaptel-1.2.16.tar.gz cd /usr/src/zaptel-1.2.16/hpec wget http://ftp.digium.com/pub/telephony/hpec/32-bit/hpec-8.20-i686.tar.gz cd /root wget http://ftp.digium.com/pub/telephony/hpec/32-bit/zaphpec_enable chmod +x zaphpec_enable wget http://ftp.digium.com/pub/register/32-bit/register chmod +x register cd /usr/src/zaptel-1.2.16/hpec tar -zxvf hpec-8.20-i686.tar.gz cd .. make make install make config service zaptel start cd /root ./register modprobe zaptel chkconfig zaptel on shutdown -r now cd /root ./zaphpec_enable

thanks!!! How do I confirm hpec is running on reboot however???