[solved] Dynamic SIP agent stuck on hold

  1. remove sip entry from sip.conf

  2. service asterisk restart

  3. add sip user to sip.conf

  4. service asterisk restart


Last week, a paticular agent began being listed as (On Hold)

Seemingly nothing has been able to bring this extension to the point of taking queue calls anymore, including:

  • login / logout
  • rebooting server
  • trying different phone with the offensive extension
  • adjusting multiple sip settings
  • combing over the dial plan

The other dynamic sip extensions receive calls while logged in, this one still does not.

asterisk version

That sounds like a problem with the device associated with the extension, but you haven’t said what the device is.

As best I remember, the only thing that can cause that status to be set is the device sending a contact address of or a media direction attribute other than sendrecv.

It is a Polycom phone sir, as was the replacement which the onsite personnel reportedly tried.

Option 66 to receive the provisioning url, but dhcp would actually assign the phone an address.

Perhaps the vlan has something to do with it, hmmm