[SOLVED] DPMA + D80 issues

I’m working with Digium phones more than a year now, and i had no issues with D40,50,70 and 6X series work with Asterisk+DPMA.
Some time ago i bought D80 for testing, and i don’t know what’s wrong with it, here’s the issues i faced configuring D80:

  • sometimes after power down cannot communicate with DPMA
  • set up account status
  • configure more than one line

NONE of this issues is present one my other phones.

My configuration:

Asterisk 16.1.1 built by root
Digium Phone Module for Asterisk Version 16.0_3.4.10
D80 Firmware - 1.9.7
Other DXX firmware - 2.8.0

What could cause this problems?


While much of the software is the same, there are some subtle differences. The platform on which it runs is completely different from the platform that the other phones run on.

You’re going to have to narrow down your issues to something actionable.

The first one is peculiar, and you’d have to figure out what’s getting stuck. Take a PCAP, see if the phone’s doing anything on the outbound side, see if Asterisk and DPMA are responding to the phone.

Account status and multi-line works4me (and for everyone using Switchvox). There’s probably something with the configuration that’s tripping things up.

Apologies in advance; I don’t have free bandwidth to troubleshoot. Good luck.

Communication problem with DPMA solved by reloading DPMA module (other phones still work great regarding of this).
There’s nothing uncommon in account lines


Though voicemail and contacts works fine on D80.
On other phones all works fine.

All issues were solved after firmware upgrade to 1.10.0
Looks like firmware below 1.10.0 does not supports multiple lines and account status.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.