Digium D50 one way audio

I am having a problem with D50 phone. I configured it on the Digium Switchvox and I am using second extension that I connect to our test Asterisk server. I have one way audio from Asterisk to the phone. I do have perfect audio stream from the phone to the Asterisk server. I connected my other phone Polycom VVX500 to the same extension and the problem goes away. IS there something I need to add to Asterisk like a package to enable Digium phones ? Does anybody have any ideas. The calls I am making are extension to extension and extension to outside via SIP provider. From the network trace I see RTP packets going into the Asterisk but nothing coming back. The regular SIP (5060) packets are present both ways only the RTP is missing from Asterisk to the phone.

The other thing is that the working Polycom is configured via custom configuration from ftp and not the Switchvox system so it is possible that the configuration on the Switchvox system is causing it.

Any help would be appreciated.

Thank you


Digium doesn’t do support via these forums, they’re a community resource. You bought a Digium product, you should contact Digium for support. Digium may be contacted via telephone - +1 256 428 6000 - or by opening a web case - digium.com/en/users/support-create-a-case/

You don’t have to add any packages to Asterisk to enable it to make/receive calls to/from Digium phones. The DPMA is a separate thing and wouldn’t apply in your situation since your phone’s being provisioned by Switchvox and you’re talking about a secondary line - the fancy features are focused around the primary line.

I am confused at this point I would call Digium as we have support contract with you guys :smile: but I thought (and I am pretty sure) the problem is with Asterisk and not Switchvox (we do not sell Asterisk nor have any support). This is why I used the forum to gather more information about the problem - maybe somebody else’s seen this behavior etc.

I tried configuring the phone directly with Asterisk with the same result. If you think that I can call Digium with this problem I will !

If you tried configuring the phone directly with Asterisk and you’re getting one-way audio, please do contact our Support department so that they can make sure you’re configuring the phone properly.

Thanks - will do today.

Obviously I did not have time to call support… I just wanted to inform that the issue went away on Switchvox 5.5.4 which updated the phones firmware to 1_1_0_0_48178.

Thank you