SOLVED: Call hangs up as soon as answered?


#1

Solved:

Someone had gone in and enabled (as preference) g729 in general settings so the calls couldn’t be bridged when the device that did support g729 initiated the calls.

Any thoughts on the following would be appreciated:

I’ve got an Asterisk Box behind a NAT (Dlink DI-624). I’ve got an Xlite Softphone behind another NAT (Linksys BEFW11S4 V2/V3). All appropraite SIP ports are forwarded on the Asterisk side (5060-80, 10000-30000, 5004 (all UDP)). Behind the same NAT as the XLite I’ve got a Sipura SPA-2002 which is also connected to the Asterisk box. The XLite is on 5060 and the Sipura is on 5061 (line 2). Both have NAT=yes and Qualify=yes. Both phones can register with Asterisk. The Xlite works fine. It can call to internal applications, it can call the Sipura extension which can be answered, it can call out on a voipjet trunk. When it calls the Sipura extension, the Sipura can answer the call, park the call, get called back if the park goes for too long. The Sipura extension can also call echo tests, voice mail, schedule a wakeup call (and get the call back).

However - when the Sipura tries to make a call, the call fails as soon as the receiving party answers the call. If I call the Xlite extension, it will ring but upon answering, the call goes dead. If I call an oustide line (voipjet trunk in this case) the call fails as soon as the outside line tries to answer the call.

Whenever the call fails, a message such as the following is reported in the debug log (external call or internal call):

Feb 18 23:46:27 WARNING[3646] channel.c: No path to translate from SIP/340-a524(4) to IAX2/voipjet-1(256)
Feb 18 23:46:27 WARNING[3646] app_dial.c: Had to drop call because I couldn’t make SIP/340-a524 compatible with IAX2/voipjet-1
Feb 18 23:46:27 DEBUG[3646] chan_iax2.c: We’re hanging up IAX2/voipjet-1 now…
Feb 18 23:46:27 VERBOSE[3646] logger.c: – Hungup ‘IAX2/voipjet-1’

Now even if I exit the Xlite phone, reboot the Sipura ATA and restart asterisk (just in case the 2nd phone was getting things confused) I still get the same behavior with the ATA.

I can connect the Sipura ATA to another another Asterisk box that is also behind a firewall and it works fine in all respects. So the configuration seems to be in reasonable shape, I think.

Any thoughts would be greatly appreciated.

p