SIP fails to register

Using asterisk 1.4.11 on a x64_64 AMD powered box. I cannot get any of my snom-360 or 370 phones to register, also trying x-lite from my pc also fails to register.
I can see via netstat that there is a udp open port listening on 5060
I can do a tcpdump on the *server and see the phone send a packet that matches the SIP trace on the phone.
Yet the phone keeps showing network failure, I assume because it doesn’t get a response it understands.
x-lite also tries and shows login times out.
sip.conf contains:
context=default ; Default context for incoming calls
allowoverlap=no ; Disable overlap dialing support. (Default is yes)
bindport=5060 ; UDP Port to bind to (SIP standard port is 5060)
bindaddr= ; IP address to bind to ( binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls


;type=friend ; Friends place calls and receive calls
;context=from-sip ; Context for incoming calls from this user
;subscribecontext=localextensions ; Only allow SUBSCRIBE for local extensions
;language=de ; Use German prompts for this user
;host=dynamic ; This peer register with us
;dtmfmode=inband ; Choices are inband, rfc2833, or info
;defaultip= ; IP used until peer registers
;mailbox=1234@context,2345 ; Mailbox(-es) for message waiting indicator
;subscribemwi=yes ; Only send notifications if this phone
; subscribes for mailbox notification
;vmexten=voicemail ; dialplan extension to reach mailbox
; sets the Message-Account in the MWI notify message
; defaults to global vmexten which defaults to “asterisk”
;allow=ulaw ; dtmfmode=inband only works with ulaw or alaw!

dtmfmode=inband ; Choices are inband, rfc2833, or info
mailbox=4560@context,4560 ; Mailbox(-es) for message waiting indicator
subscribemwi=yes ; Only send notifications if this phone
; subscribes for mailbox notification
vmexten=voicemail ; dialplan extension to reach mailbox
; sets the Message-Account in the MWI notify message
; defaults to global vmexten which defaults to "asterisk"
allow=ulaw ; dtmfmode=inband only works with ulaw or alaw!



Fred is the phone I’m trying and 1230 is x-lite.
I’m missing something obvious but for the life of me cannot fathom what it is.
BTW there is no firewall running on the *server and they are all on the same Netgear FS726TP switch.

  • sip show peers :
    [ul]asterisk1*CLI> sip show peers
    Name/username Host Dyn Nat ACL Port Status
    1230/1230 5060 Unmonitored
    Ed/Ed 5060 Unmonitored
    Fred/Fred 5060 Unmonitored
    Rob/Rob 5060 Unmonitored
    4 sip peers [Monitored: 0 online, 0 offline Unmonitored: 4 online, 0 offline]
  • sip show users:
    [ul]asterisk1*CLI> sip show users
    Username Secret Accountcode Def.Context ACL NAT
    1230 from-sip No RFC3581
    Ed 978E from-sip No RFC3581
    Fred 978F from-sip No RFC3581
    Rob 0579 from-sip No RFC3581
    so now what?
    Any ideas appreciated.
    Sorry about formatting - never seem to get that right.

Do you have localnet set up on the server ? Also why are you using their IP’s for authentication. If you run ngrep on port 5060 what do you get ?

Hi, not sure what you mean by localnet set up on server - the server ip is and it has no problem communicating with the snom phones via http - both ways.
What do you mean by using the IPs for authentication - In the sip file I define each users device IP rather than use DHCP, for their password at this time i’m using the last four digits of their ethernet address.
ngrep port 5060 shows:
[ul]interface: eth0 (
filter: (ip) and ( port 5060 )

U ->
REGISTER sip:asterisk1 SIP/2.0…Via: SIP/2.0/UDP;branch=z9hG4bK-lrguga7qqp3l;rport…From: “Fred” sip:Fred@asterisk1;ta
g=wv5j1mernl…To: “Fred” sip:Fred@asterisk1…Call-ID: 3c267009a875-h1d9t6k9jzeg@snom360-00041323978F…CSeq: 3126 REGISTER…Max-Forwards: 7
0…Contact: sip:Fred@;line=v08f5dkc;flow-id=1;q=1.0;+sip.instance=“urn:uuid:190f2242-0189-4170-8e07-2e17317638ab”;aud
Y,SUBSCRIBE,PRACK,MESSAGE,INFO”…User-Agent: snom360/6.5.10…Supported: gruu…Allow-Events: dialog…X-Real-IP:…WWW-Contact:…WWW-Contact:…Expires: 3600…Content-Length: 0…
This appears to match what the phone is showing on the SIP trace.
Still not registering as neither asterisk acknowledges the phones presence and the phone does not appear to get a response.

First of all, you would do well to ditch the naming convention you’re using.

Make the [sip] definition the extension (as you see with extension 1230).

The phone login username should also be the extension.

If you make the username an alpha word, you won’t be able to dial any of the stations using a touch tone pad. (How do you dial “fred” when all you have are the digits 0-9, *, and #?)

Change the dtmf mode to rfc2833. It’s how SIP phones are generally designed.

Thanks for the suggestions, none of these appear address the issue I’m having. I have done as suggested so now I have:
context=default ; Default context for incoming calls
allowoverlap=no ; Disable overlap dialing support. (Default is yes)
bindport=5060 ; UDP Port to bind to (SIP standard port is 5060)
bindaddr= ; IP address to bind to ( binds to all)
srvlookup=yes ; Enable DNS SRV lookups on outbound calls





made the changes to the phone and still no registration and both the snom-360 and the x-lite phones show network error.

I tried a

and get

every minute as the phone attempts to re-register, so I guess *server is not replying???
Where to from here?

Ok… now I have to ask a not-so-obvious question…

Did you go into the phones, and setup the user, password, resgistration server, outbound proxy, MWI server, voicemail server, music on hold server, conference server, NTP server, and all the other settings that a phone needs to connect to Asterisk?

The sip.conf files doesn’t make changes to your phones. It’s what the phones themselves have to match in order to be allowed to use the system’s resources.

Think of it more like an email system. If you don’t have an email account on the the email server, you can’t use the server to send and receive messages. Asterisk would be like the email server.

Like any other server, Asterisk need clients. These clients are phones, and the phones themselves need to know about their “accounts”, on the various servers that will supply them all of their phone services.

So you setup the “account” in the Asterisk sip.conf, and then setup the “client” in the phone. Each phone will have differnet settings and setup methods… be sure to check their documentation.

To re-ask the question that Dovid asked, why specify the IP address of the sip.conf file? You don’t have to, and it’s probably better if you don’t. It restricts the login of a particular SIP client, so that it can only login if it has that specific IP address. If your phones are getting an address by DHCP, and it doesn’t match the SIP profile in sip.conf, it won’t work.

No problem with the not so obvious question.
Yes I have changed all the settings on the phone. We are not using a proxy, and MWI can wait until I get the basics working. I have followed the handset manufacturers setup instructions for asterisk.
Not using DHCP as I am not interested in roaming of the handsets, and by specifying the IP I retain some measure of control and security.
Each phone can and is getting its settings from a specific phone file hosted on the *server by apache. This is working fine as I can see the changes once the phone reboots via the phone’s web portal i.e.
I have traced the SIP REGISTER udp packet from the phone, and then via tcpdump and ngrep as arriving unaltered at the *server on port 5060.
At that point it appears to get lost, I don’t know how to trace what asterisk is doing once (if) it is getting the register request.
There is nothing leaving the *server destined for the phone, so the phone says network error.
So I’m asking for some ideas of what to check next, preferably from the asterisk CLI…

My best suggestion is to leave the host IP address unspecified.

You can lock it down later after you get it all working.

I seem to remember needing to maintain the hosts file in the Asterisk server when I tried that…

Well I’ve set the phone for DHCP and modified the sip.conf for host=dynamic.
No difference.
Still does not register, phone still shows network failure.

What command, if any, is available to monitor asterisk’s response to a SIP register request?

I cannot believe how difficult it is to get something basic like this functioning.
I have now spent about 100+ hours trying different set-ups, two re-installs of asterisk, read 100’s of web pages, followed many different step by step instructions, purchased and read most of the book, Asterisk - The future of Telephony and still no joy.

I am not a computer novice, have spent over 20 years in the telecommunications industry, but never come across something so difficult to get going. Compared to this, getting my myth-tv box jumping through hoops was a walk in the park.
I tried a trixbox install and found it didn’t like my hardware combo, so I started with a very basic Centos el5 install, manual install and compilation of asterisk along with all the other bits, following the many different examples on the internet.

I am missing something very basic, I’m sure, but need some guidance about how this SIP REGISTER process works so I can determine what is tripping me up.
HELP :frowning:

Could this be something as simple as a hardware failure?

Maybe you’ve got a bad Ethernet NIC, or a bad cable or wiring to your switch…

I’ve not seen troubles like yours very often.

The only other piece of advice I might have would be to try setting the phones manually instead of using the configuration file. An explicit setting in the web interface may be different.

Go through EVERYTHING in the setup. Include your Asterisk box in every setting for registration, voicemail, outbound proxy, everything…

You might also check to see if there’s a firmware update for the phones.

I do not believe there is a hardware failure as the box communicates fine on port 80 for apache, also via port 22 for ssh access.
I have also manually loaded the required settings into the phones and upgraded the software on one of the phones - still no joy.
Also as x-lite soft phone running on another workstation also cannot connect to the *server, I am led to think this is strictly an asterisk SIP issue.
I am going to upgrade to the latest version of asterisk and see if that makes any difference…
grasping at any thing at this point.
Still have a question for anyone that knows how to trace progress of a SIP REGISTER request within asterisk???
It appears that nothing comes out of the asterisk box in response to a SIP REGISTER packet.

you asked for wild ass guesses too and I have seen the behavior you are reporting happen on asterisk. in the one observation of this, it was when there were multiple IP addresses bound to the NIC. The SIP phones would try to register to one IP address on the NIC but the reply would come from the other address. This did not affect SSH or HTTP which worked just fine. The fix was to go into sip.conf and iax.conf and change the IP binding from the default [all addresses] to the specific addresses you want to use for SIP & IAX.

May be totally irrelevant to your condition but the symptoms match.

Still no progress.
I now have a clean install of * 1.4.14 with libpri 1.4.1; rhino-2.2.1; zaptel-1.4.6
no errors in compile or install
wiped /etc/asterisk and did a "make samples"
now my sip.conf

context=congest-sip             ; Default context for incoming calls
allowoverlap=no                 ; Disable overlap dialing support. (Default is yes)
bindport=5060                   ; UDP Port to bind to (SIP standard port is 5060)
bindaddr=         ; IP address to bind to ( binds to all)
srvlookup=yes                   ; Enable DNS SRV lookups on outbound calls
allow=all                       ; Allow all codecs




So you will see I have now bound to the ip address explicitly.
Still no joy, either from my phones or from x-lite running on my fc6 workstation.
Looking at various forums, it appears that the *CLI can be set to trace progress, and there is one site where someone posts a listing of the SIP messages that occur during a REGISTER - i.e. the dialog going each way.
How do I get to trace like this?
I know that the initial request is getting to the server and that asterisk is listening on port 5060. Now I need to see what asterisk is doing with this request - how does this occur?

In your new sip.conf file, your secret (sip client password) is commented out. Did you intend that?

The semicolon is used as a comment mark in Asterisk .conf files due to the fact the pound sign (#) is a dtmf key and is likely to be used in dialplan programming.

When starting Asterisk, use:

asterisk -vvvvc

That will put Asterisk in verbose mode. You will see call progress and other system messages on the CLI> screen.

I am aware of commenting out the password/secret - one site suggested trying this - that’s why it like that.
What is of more concern is that I see nothing coming up on the *CLI
I have even tried * -vvvvvgcdr - still nothing comes up - this may be getting close to the problem, asterisk is not actually hearing or responding, nothing coming in on the *CLI.
Are there any global configurations that could be wrong that stop the *server?
I believe that I have rigorously followed the install instructions, so not sure what to check next.
Yet sip show users and sip show peers give me indications that the system is kind of there, but I never see anything else - even sip set debug gives nothing.
I’m real confused… :confused:

Ok… that’s strange.

Are you sure that Asterisk is actually running?

What do you see if you execute the:

show modules

command? Are you not getting any response at all?

And you’re CERTAIN that iptables isn’t running on this box?

module show gives

Module Description Use Count Music On Hold Resource 0 Call Features Resource 0 Generic Speech Recognition API 0 Indications Resource 0 Asterisk Gateway Interface (AGI) 0 ADSI Resource 0 Simplified Message Desk Interface (SMDI) 0 Call Monitoring Resource 0 Cryptographic Digital Signatures 0 iLBC Coder/Decoder 0 Linux Telephony API Support 0 Zap RAS Application 0 Music-on-hold dialplan function 0 Set ISDN Transfer Capability 0 Send URL Applications 0 Indicator for whether a voice mailbox ha 0 Asterisk ADSI Programming Application 0 Cut out information from a string 0 Database Access Functions 0 Get ADSI CPE ID 0 Dialplan Speech Applications 0 Channel language dialplan function 0 Skinny Client Control Protocol (Skinny) 0 Mathematical dialplan function 0 Trivial Record Application 0 Logical dialplan functions 0 Scan Zap channels application 0 Zapata Telephony 0 Listen to the audio of an active channel 0 Realtime Switch 0 Skeleton (sample) Application 0 Agent Proxy Channel 0 Raw G729 data 0 Virtual Dictation Machine 0 LPC10 2.4kbps Coder/Decoder 0 Silly NBS Stream Application 0 File format conversion CLI command 0 String handling dialplan functions 0 SMS/PSTN handler 0 Call origination from the CLI 0 Say time 0 Check channel availability 0 A-law Coder/Decoder 0 Simple Echo Application 0 Outgoing Spool Support 0 GSM Coder/Decoder 0 Look up Caller*ID name/number from black 0 Raw iLBC data 0 Interface Test Application 0 Set CallerID Application 0 Find-Me/Follow-Me Application 0 Send verbose output 0 ITU G.726-32kbps G726 Transcoder 0 Image Transmission Application 0 Comma Separated Values CDR Backend 0 Generic System() application 0 Microsoft WAV format (Proprietary GSM) 0 Send Text Applications 0 Dump Info About The Calling Channel 0 Playback with Talk Detection 0 Random goto 0 Dialogic VOX (ADPCM) File Format 0 Flash channel application 0 CDR dialplan function 0 OSS Console Channel Driver 0 Text Extension Configuration 0 Asterisk Manager Interface CDR Backend 0 Digital Milliwatt (mu-law) Test Applicat 0 mu-Law Coder/Decoder 0 Barge in on Zap channel application 0 Custom User Event Application 0 Call Parking and Announce Application 0 True Call Queueing 0 Require phone number to be entered, if n 0 Channel information dialplan function 0 MD5 digest dialplan functions 0 Local Proxy Channel 0 Channel Redirect 0 Dialing Application 0 Hangs up the requested channel 0 Page Multiple Phones 0 Raw Signed Linear Audio support (SLN) 0 CDR user field apps 0 Control Playback Application 0 Tell Asterisk to not maintain a CDR for 0 Alarm Receiver for Asterisk 0 Raw G.726 (16/24/32/40kbps) data 0 URI encode/decode dialplan functions 0 Realtime Data Lookup/Rewrite 0 Session Initiation Protocol (SIP) 0 Directed Call Pickup Application 0 Raw GSM data 0 Executes dialplan applications 0 MeetMe conference bridge 0 Block Telemarketers with Special Informa 0 Wait For Silence 0 Sound File Playback Application 0 Media Gateway Control Protocol (MGCP) 0 Database (astdb) related dialplan functi 0 Morse code 0 Look up CallerID Name from local databas 0 Raw H.264 data 0 ENUM related dialplan functions 0 Customizable Comma Separated Values CDR 0 Mixed Audio Monitoring Application 0 Inter Asterisk eXchange (Ver 2) 0 Transfer 0 Extension Directory 0 Read Variable Application 0 Send DTMF digits Application 0 JPEG (Joint Picture Experts Group) Image 0 Raw/Sun uLaw/ALaw 8KHz (PCM,PCMA,AU), G. 0 Loopback Switch 0 Generic Zaptel Transcoder Codec Translat 0 Caller ID related dialplan function 0 OGG/Vorbis audio 0 Channel group dialplan functions 0 Stores output of file into a variable 0 Adaptive Differential PCM Coder/Decoder 0 Global variable dialplan functions 0 SHA-1 computation dialplan function 0 Microsoft WAV format (8000Hz Signed Line 0 External IVR Interface Application 0 While Loops and Conditional Execution 0 Channel timeout dialplan functions 0 Waits until first ring after time 0 G.723.1 Simple Timestamp File Format 0 A-law and Mulaw direct Coder/Decoder 0 Fork The CDR into 2 separate entities 0 Encode and Stream via icecast and ices 0 Environment/filesystem dialplan function 0 Raw H.263 data 0 base64 encode/decode dialplan functions 0 Silly MP3 Application 0 Distributed Universal Number Discovery ( 0 Extension Macros 0 Answering Machine Detection Application 0 Authentication Application 0 Read/Write values from a RealTime reposi 0 Stack Routines 0 Random number dialplan function 0 Comedian Mail (Voicemail System) 0 Asterisk Extension Language Compiler 0 Simple Festival Interface 0 DISA (Direct Inward System Access) Appli 0 145 modules loaded
and this shows - which is I assume the bit that does SIP…?
and just in case you can recognize another problem here is

root         1     0  0 Nov19 ?        00:00:00 init [5]                             
root         2     1  0 Nov19 ?        00:00:00 [migration/0]
root         3     1  0 Nov19 ?        00:00:01 [ksoftirqd/0]
root         4     1  0 Nov19 ?        00:00:00 [watchdog/0]
root         5     1  0 Nov19 ?        00:00:00 [migration/1]
root         6     1  0 Nov19 ?        00:00:01 [ksoftirqd/1]
root         7     1  0 Nov19 ?        00:00:00 [watchdog/1]
root         8     1  0 Nov19 ?        00:00:00 [events/0]
root         9     1  0 Nov19 ?        00:00:00 [events/1]
root        10     1  0 Nov19 ?        00:00:00 [khelper]
root        26     1  0 Nov19 ?        00:00:00 [kthread]
root        31    26  0 Nov19 ?        00:00:00 [kblockd/0]
root        32    26  0 Nov19 ?        00:00:00 [kblockd/1]
root        33    26  0 Nov19 ?        00:00:00 [kacpid]
root       156    26  0 Nov19 ?        00:00:00 [cqueue/0]
root       157    26  0 Nov19 ?        00:00:00 [cqueue/1]
root       160    26  0 Nov19 ?        00:00:00 [khubd]
root       162    26  0 Nov19 ?        00:00:00 [kseriod]
root       237    26  0 Nov19 ?        00:00:00 [pdflush]
root       238    26  0 Nov19 ?        00:00:00 [pdflush]
root       239    26  0 Nov19 ?        00:00:00 [kswapd0]
root       240    26  0 Nov19 ?        00:00:00 [aio/0]
root       241    26  0 Nov19 ?        00:00:00 [aio/1]
root       383    26  0 Nov19 ?        00:00:00 [kpsmoused]
root       415    26  0 Nov19 ?        00:00:00 [ata/0]
root       416    26  0 Nov19 ?        00:00:00 [ata/1]
root       417    26  0 Nov19 ?        00:00:00 [ata_aux]
root       421    26  0 Nov19 ?        00:00:00 [scsi_eh_0]
root       422    26  0 Nov19 ?        00:00:00 [scsi_eh_1]
root       423    26  0 Nov19 ?        00:00:00 [scsi_eh_2]
root       424    26  0 Nov19 ?        00:00:00 [scsi_eh_3]
root       428    26  0 Nov19 ?        00:00:00 [scsi_eh_4]
root       429    26  0 Nov19 ?        00:00:14 [usb-storage]
root       431    26  0 Nov19 ?        00:00:00 [kjournald]
root       464    26  0 Nov19 ?        00:00:00 [kauditd]
root       498     1  0 Nov19 ?        00:00:00 /sbin/udevd -d
root      1099    26  0 Nov19 ?        00:00:00 [kedac]
root      1368    26  0 Nov19 ?        00:00:00 [hda_codec]
root      1702    26  0 Nov19 ?        00:00:00 [kmirrord]
root      1726    26  0 Nov19 ?        00:00:00 [kjournald]
root      1728    26  0 Nov19 ?        00:00:00 [kjournald]
root      2171     1  0 Nov19 ?        00:00:00 /usr/sbin/restorecond
root      2183     1  0 Nov19 ?        00:00:00 auditd
root      2185  2183  0 Nov19 ?        00:00:00 python /sbin/audispd
root      2199     1  0 Nov19 ?        00:00:00 syslogd -m 0
root      2202     1  0 Nov19 ?        00:00:00 klogd -x
root      2214     1  0 Nov19 ?        00:00:00 irqbalance
root      2230     1  0 Nov19 ?        00:00:00 mcstransd
rpc       2243     1  0 Nov19 ?        00:00:00 portmap
root      2256     1  0 Nov19 ?        00:00:00 /usr/bin/python -E /usr/sbin/setroubleshootd
root      2277     1  0 Nov19 ?        00:00:00 rpc.statd
root      2311     1  0 Nov19 ?        00:00:00 rpc.idmapd
dbus      2331     1  0 Nov19 ?        00:00:00 dbus-daemon --system
root      2343     1  0 Nov19 ?        00:00:00 /usr/sbin/hcid
root      2347     1  0 Nov19 ?        00:00:00 /usr/sbin/sdpd
root      2369     1  0 Nov19 ?        00:00:00 [krfcommd]
root      2409     1  0 Nov19 ?        00:00:00 pcscd
root      2425     1  0 Nov19 ?        00:00:00 /usr/bin/hidd --server
root      2446     1  0 Nov19 ?        00:00:00 automount
root      2467     1  0 Nov19 ?        00:00:00 /usr/sbin/acpid
root      2478     1  0 Nov19 ?        00:00:00 ./hpiod
root      2483     1  0 Nov19 ?        00:00:00 python ./
root      2495     1  0 Nov19 ?        00:00:00 cupsd
root      2509     1  0 Nov19 ?        00:00:00 /usr/sbin/sshd
root      2521     1  0 Nov19 ?        00:00:00 xinetd -stayalive -pidfile /var/run/
ntp       2535     1  0 Nov19 ?        00:00:00 ntpd -u ntp:ntp -p /var/run/ -g
root      2555     1  0 Nov19 ?        00:00:00 sendmail: accepting connections
smmsp     2564     1  0 Nov19 ?        00:00:00 sendmail: Queue runner@01:00:00 for /var/spool/clientmqueue
root      2576     1  0 Nov19 ?        00:00:00 gpm -m /dev/input/mice -t exps2
root      2614     1  0 Nov19 ?        00:00:00 crond
xfs       2653     1  0 Nov19 ?        00:00:00 xfs -droppriv -daemon
root      2674     1  0 Nov19 ?        00:00:00 /usr/sbin/atd
root      2702     1  0 Nov19 ?        00:02:09 /usr/bin/python /usr/sbin/yum-updatesd
avahi     2734     1  0 Nov19 ?        00:00:00 avahi-daemon: running [asterisk1.local]
avahi     2735  2734  0 Nov19 ?        00:00:00 avahi-daemon: chroot helper
68        2749     1  0 Nov19 ?        00:00:01 hald
root      2750  2749  0 Nov19 ?        00:00:00 hald-runner
68        2756  2750  0 Nov19 ?        00:00:00 hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
root      2766  2750  0 Nov19 ?        00:00:12 hald-addon-storage: polling /dev/hdd
root      2768  2750  0 Nov19 ?        00:00:02 hald-addon-storage: polling /dev/sde
root      2770  2750  0 Nov19 ?        00:00:01 hald-addon-storage: polling /dev/sdd
root      2772  2750  0 Nov19 ?        00:00:01 hald-addon-storage: polling /dev/sdc
root      2774  2750  0 Nov19 ?        00:00:01 hald-addon-storage: polling /dev/sdb
root      2851     1  0 Nov19 ?        00:00:00 /usr/sbin/smartd -q never
root      2857     1  0 Nov19 tty1     00:00:00 /sbin/mingetty tty1
root      2858     1  0 Nov19 tty2     00:00:00 /sbin/mingetty tty2
root      2860     1  0 Nov19 tty3     00:00:00 /sbin/mingetty tty3
root      2862     1  0 Nov19 tty4     00:00:00 /sbin/mingetty tty4
root      2863     1  0 Nov19 tty5     00:00:00 /sbin/mingetty tty5
root      2864     1  0 Nov19 tty6     00:00:00 /sbin/mingetty tty6
root      2866     1  0 Nov19 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      2963  2866  0 Nov19 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      2967     1  0 Nov19 ?        00:00:00 /usr/sbin/gdm-binary -nodaemon
root      2970  2963  0 Nov19 tty7     00:00:00 /usr/bin/Xorg :0 -br -audit 0 -auth /var/gdm/:0.Xauth -nolisten tcp vt7
gdm       2989  2963  0 Nov19 ?        00:00:00 /usr/libexec/gdmgreeter
root     21362  2509  0 12:39 ?        00:00:00 sshd: rkampen [priv]
rkampen  21364 21362  0 12:39 ?        00:00:00 sshd: rkampen@pts/1
rkampen  21365 21364  0 12:39 pts/1    00:00:00 -bash
root     21435     1  0 12:42 pts/1    00:00:00 /bin/sh /usr/sbin/safe_asterisk
root     21442 21435  0 12:42 pts/1    00:00:03 /usr/sbin/asterisk -f -vvvg -c
root     21890 21365  0 16:15 pts/1    00:00:00 ps -ef

Frankly, I’m stumped.

Everything looks ok on the Asterisk side.

I’m guessing you found this page, but just in case you haven’t…

Well the plot thickens…
If I set the sip.conf file for the x-lite [1230] with port= and then use the *CLI> dial 1230 the call goes through (haven’t checked audio as not set up for this on the workstation). When I hang-up the call from either end it works and hangs up the call.
Then the x-lite tries to register (as it does every minute until registered) and the *CLI shows:

[Nov 26 15:51:55] ERROR[2992]: chan_sip.c:8513 register_verify: Peer '1230' is trying to register, but not configured as host=dynamic [Nov 26 15:51:55] NOTICE[2992]: chan_sip.c:14943 handle_request_register: Registration from 'RobsWS <>' failed for '' - Peer is not supposed to register
so from this it appears the *server only expects SIP REGISTER from those clients that have host=dynamic - great if the documentation told me this!:evil:
So then I change the sip.conf file and make it host=dynamic and hey presto it registers.
Problem is, until I actually make a call (and apparently open a port) to the device, the *server does not see the REGISTER request.
This really looks like a firewall issue - yet I am certain that iptables is not running on either my workstation or the *server, and both the *server and all the phones including x-lite are on the same subnet (
Go figure…
However this still leaves me with a problem for all my snom-360 phones as they are trying to SIP REGISTER every minute but these requests are not seen by the *server. I tried the same trick that worked with the x-lite but this did not work for the hardware phones.

I really am missing something basic. Is there some other parameter I need to set in sip.conf? All my reading shows that I have the basics in place but no joy :frowning:
The book Asterisk - The Future of Telephony, second edition does not help, indeed all the online forums and docs I have looked at seem to deal with setting up and helping folk achieve the basic installation of software and setup of particular situations e.g. getting MWI to work…
Where do I go to get an understanding of the sip channel driver and an overview of how asterisk expects this to work.
I note that *server is not considered a sip proxy server, but rather a sip agent or end-point - I sure do not understand the implications of that.
Some suggested reading somewhere??? I am happy to do my home work but so far google and the various forums have not been much help.
Thanks for suggestions thus far, I’ll keep going as I have committed too much to pull back now.

BTW - the
asterisk*CLI>sip show peers
shows my devices and says that the status is Unmonitored for all of them.
What does this mean?
how do I get a phone / peer to be Monitored?