Can't register X-Lite softphone

Hello Folks, I am a newbie at this. We recently installed Asterisk 1.4, and I recently downloaded the X-Lite Softphone. I am trying to follow the example in the on-line version of the O’Reilly book.

Asterisk is loaded on a Linux box with a fixed IP address. The phone is loaded on to my Windows PC, also with a fixed IP address. So in the sip.conf file, I define an extesion [1000], type=friend, context=phones, host={my PC IP addr}. In the settings of the phone, I give it an account name of 1000, and for the domain value, I have the IP address of the Asterisk box.

Everytime I try to register, I get a timeout, value 408.

Any ideas?

Tnx,

– Mark

Please post your sip.conf file along with any output from the Asterisk CLI.

Thanks. Here it is:

localhostCLI> dialplan reload
Dialplan reloaded.
== Parsing ‘/etc/asterisk/extensions.conf’: Found
– Registered extension context ‘default’
– Added extension ‘s’ priority 1 to default
– Added extension ‘s’ priority 2 to default
– Added extension ‘s’ priority 3 to default
– Added extension ‘s’ priority 4 to default
– Added extension ‘s’ priority 5 to default
– Registered extension context ‘incoming_calls’
– Registered extension context ‘internal’
– Added extension ‘500’ priority 1 to internal
– Added extension ‘500’ priority 2 to internal
– Added extension ‘500’ priority 3 to internal
– Registered extension context ‘phones’
– Including context ‘internal’ in context ‘phones’
== Parsing ‘/etc/asterisk/users.conf’: Found
localhost
CLI> sip reload
Reloading SIP
== Parsing ‘/etc/asterisk/sip.conf’: Found
== Parsing ‘/etc/asterisk/users.conf’: Found
localhostCLI> stop now
localhost
CLI>
Disconnected from Asterisk server
Executing last minute cleanups
[root@localhost asterisk]# Asterisk ended with exit status 0
Asterisk shutdown normally.

[root@localhost asterisk]# cat sip.conf
[general]
;context=default
;allowoverlap=no
;bindport=5060
;bindaddr=0.0.0.0
;srvlookup=yes

[1000]
type=friend
context=phones
host=10.0.0.64 < my PC address
;host=dynamic

[1005]
type=friend
context=phones
host=10.0.0.154 < a colleague’s attempt; also doesn’t work

[authentication]

[root@localhost asterisk]#

For the X-Lite phone properties, I have domain = 10.0.0.154 (Asterisk box) and “send output via: domain”. The “register with domain and receive incoming calls” box is checked.

– Mark

Can you post the output from the Asterisk CLI when the register event occurs? I have also posted a sample sip.conf entry i use.


[7777]
defaultuser = 7777
callerid=77777
type = friend
context = sales-context
secret = 1234567890
host = dynamic
mailbox = 7777@domain
dtmfmode=rfc2833
disallow = all
allow = ulaw
nat = yes
qualify = yes

Thanks for this.

I see no CLI output from the time the registration attempt begins until the phone displays the 408 error message. That suggests that either the issue is with the phone or I need to enter a command to enable the output of the registration attempt.

On the phone settings, the “enabled” box is checked. The user name and authorization user name are both ‘1000’. The domain value is 10.0.0.154, the IP address of the Asterisk box. The “Domain Proxy” setting is set to “Domain”. The “dialing plan” value is “#1\a\a.T;match=1;prestrip=2;”. In the Topology section of the phone properties, the “IP address” value is set to “use local IP address”. The “STUN server” value is set to “use specified server” and the value is 10.0.0.154, the IP address of the Asterisk box. The “port used on local computer” box is unchecked (does this need to be set to 5060 or 5061?).

Thanks again,

– Mark

Ensure that your asterisk box is accepting connections on port 5060 on UDP. You can use portqry if you are on a windows machine, the command is as below. The output should state "LISTENING or FILTERED.

portqry.exe -n asterisk-ip -e 5060 -udp

What you should see on the asterisk CLI after a successful registration is shown below.

[Jul 14 15:51:29] NOTICE[28005]: chan_sip.c:18324 handle_response_peerpoke: Peer '1000' is now Reachable. (12ms / 2000ms)

Thanks for this suggestion. I’m thinking our problem is a networking problem. Is there anything sacred about port 5060, or is that an arbitrary value that can be changed?

Tnx,

– Mark

It’s the default port for SIP registration. Check out http://www.asteriskguru.com/tutorials/sip_nat_oneway_or_no_audio_asterisk.html

Hi As these are phones set the host to dynamic

and set sip.conf to be similar

[general]
context=default
allowoverlap=no
bindport=5060
bindaddr=0.0.0.0
srvlookup=yes

[1000]
type=friend
context=phones
host=dynamic
deny=all
allow=ulaw
allow=alaw
;host=dynamic

Ian

please disaple firewall and selinux, then you will be able to register it
Good Luck!!