Asterisk not registering ... no packets at all


#1

I’ve got an Asterisk 1.2.6 machine running CentOS 4.3. At one point I’m pretty sure I had this working but now it’s not. I’m using FreePBX as the front end but have tried doing things by hand as well.

Here’s the sip.conf that I have.

register=12345:password@sip.myprovider.net:5060

[12345]
username=12345
type=friend
secret=password
nat=yes
host=sip.myprovider.net
fromuser=12345
fromdomain=sip.myprovider.net
dtmfmode=rfc2833
context=from-pstn
insecure=very

I’ve also tried other various things like having a ‘peer’ and a ‘user’ section and I’ve tried changing the ‘=’ in the register to a ’ => '.

The problem is I don’t see any attempt by asterisk to register with my provider (Telco Nortel DMS10). I can register a Grandstream GXP-2000 with no problems to my provider and it works great. I can also register a Polycom 301 without issue.

I have a tethereal packet capture running watching everything but ssh out of this box. I can restart Asterisk and nothing exciting happens. I get a DNS SRV lookup with no issue. If I take my SRV record out, then DNS lookup works as I would expect. However, there is no registration attempt to the SIP provider at all after DNS is obtained. I can ping the sip provider’s address so I know that I can get there. Even at that, I should see at least an attempt.

I am behind a NAT box (Cisco PIX515E with SIP inspection turned off). I have even tried from outside the PIX with no success so I’m pretty confident that’s not the issue.

Any thoughts or help would be appreciated. If more config information is needed please let me know and I’ll do my best to get what is needed to help solve this problem.

Thanks,
Charlie


#2

Ended up pulling the whole config and all binaries off the machine and rebuilt. That seems to have fixed it. Very strange though. Maybe a typo somewhere or something but why would DNS even have worked then? Strange.

Thanks to anyone who looked.