SIP conflicts with zaptel?


#1

Hello,

I have strange problem installing Asterisk (both 1.0.7 from Debian and 1.2-beta-1 from sources) on my Debian (stable, kernel 2.6.13.4). After installation (including samples), Asterisk starts without problems, SIP phones (X-Lite on Windows and LinPhone on Linux) registers fine, dialing 500 and 1000 demo numbers work - but there is no audio coming back from server, it is completely quiet. On the asterisk console I can see no error messages, just notices about playing the samples.

The strange thing is, everything work perfectly when I unload kernel modules for my TE205P card (using 1.0.9 drivers for Asterisk 1.0.7 and 1.2-beta1 for 1.2-beta1). There are no error messages related to the zaptel drivers, neither on Asterisk console, nor in dmesg.

Exactly same thing happens in both Asterisk 1.0.7 and in 1.2-beta1.

I did no changes to configuration, except for adding clients for the sip phones.

Can anybody please help me? Thanks in advance 8) (I’m sorry if I missed something obvious, but I spent whole day on this problem…)


#2

I’m going to guess that one of two things is probably true;

  1. You have an interrupt conflict with your board, and the system is having performance problems.

  2. You have some firewall sofrtware on your Asterisk box that would block the RTP ports.

Check both.


#3

Hmm, I think I nailed the problem. First, I tried to disable all unused devices in the system to free up some IRQs and to avoid IRQ sharing between Digium card and other device. It did not helped. But then I run ztcfg (for first time), and it immediatelly worked. I’m not quite sure this is a bug, as it can be expected to have the card configured before running asterisk, but it is at least unexpected behaviour, since there were no error messages (or at least I did not noticed any) and docs says that some tests (dial 500 and 1000) can be done without any configuration.