Random abrupt console dsp sound

my problem is that if i call the asterisk server i get abrupt strange sound sometimes played over oss on the server - so talkin’ 5-20s perfect quality and then i get a sound like a “helicopter”;). The way back works perfect. It doesn’t matter which sip phone, softphone, codec, asterisk the calling person is.
The soundcard works perfect if i play a mp3 etc. First i thought it’s a audio chipset (GEODE LX 800, ETX module, AMD, CS5535) problem, so i tried the actual kernel on my etch debian system, but the problem is still the same.
I recognized a kernel log message from the audio device:
[ul]curdma=1d2de00 < 1dcf0000 bufaddr
diff=f00 >= f00 buf_bytes.[/ul]
That sound to me like a buffer problem?
Asterisk in debug/vebrosity mode says a warning:
[ul][Jun 19 17:27:20] WARNING[2337]: chan_oss.c:1037 oss_request: oss_request ty data 0x0xb6c28cb0
<< Call to device ‘dsp’ dnid ‘(null)’ rdnis ‘(null)’ on console from ‘2001’ <2001> >>[/ul]
Does anyone know what that means? (the calling sip phone is 2001)
Thank you for any idea!!!

R u using Zaptel ??

I faced same problem during zaptel to Sip bridge many times.

Remove echo cancellation on from Zapata.conf if you are using bridge between zaptel to sip and test the result

no I use no Zaptel - just a blank asterisk latest version
I really guess it’s a Kernel driver problem, but so far Asterisk is the only application, which generate this error…

del me

found the solution or workaround - found two parameters in the oss.conf and changed them (have to optimize now) and the helicopter sound with the driver message is gone. But I’m not really sure what happend between Asterisk-OSS and the sound driver.

queuesize 10 -> 5
frags 8 -> 10