SIP command missing in asterisk 1.4.22

I just downloaded and built asterisk 1.4.22 and installed it on Centos 5.2

CLI> core show version
Asterisk 1.4.22 built by root @ XXX on a i686 running Linux on 2008-11-21 21:31:31 UTC

I have created an extension 2001 but the SIP client SJ-Phone is unable to register to the server

CLI> sip show users
No such command ‘sip show users’ (type ‘help sip show’ for other possible commands)

Any idea what is missing here.

Appreciate your support.


Connected to Asterisk 1.4.22 currently running on cymon (pid = 6867) Verbosity is at least 1 cymon*CLI> sip show users Username Secret Accountcode Def.Context ACL NAT

definitely there.

when you did make menuconfig you did have sip selected

[*] 12. chan_oss [*] 13. chan_phone [*] 14. chan_sip

I would go back over it and recompile



All the channels are were selected, see below.
[] 1. chan_agent
] 2. chan_alsa
[] 3. chan_dahdi
[ ] 4. chan_features
XXX 5. chan_gtalk
XXX 6. chan_h323
] 7. chan_iax2
[] 8. chan_local
] 9. chan_mgcp
XXX 10. chan_misdn
XXX 11. chan_nbs
[] 12. chan_oss
] 13. chan_phone
[] 14. chan_sip
] 15. chan_skinny
XXX 16. chan_vpb
May be something else , IS there an option to load SIP modules somewhere??

Sounds silly but have you restarted asterisk? Worked for me when I was missing all the SIP commands after a new install of 1.4.22.


Thanks for all the help!

I had to enable the debug_threads option to get the sip show commands.

I dont know if that was the root cause but it worked.