Sip is not in the CLI

My Asterisk 1.4 server dies. So I installed Asterisk came up, but the CLI does not included any sip commands. I assume I failed to properly compile and install the sip module.

Where do I look for documentation regarding getting sip installed? I’ve been over the documentation for way too many hours.

Any suggestions would be much appreciated,

Run make menuconfig and try to enable sip. It will show you which dependencies are missing.

1 Like

You could try ‘module load chan_sip’ from the CLI and see if it’s there first. Otherwise, it’s probably not installed. I ran into the same thing upgrading from 13.5 to 13.8. chan_sip is not checked in the menuconfig by default.

Great call, thanks much.
When I ran module load chan_sip, it failed with errors in my Users.conf. I forgot to copy all my context config files. Once I copied them, sip was available, as well as sip commands being listed in the help in the CLI.
Thanks much.

However my phones are still not registering. Did version 1.8 obsolete the users.conf file? That is where my phone are defined. Do I need to define them in sip.conf? I thought that would not start until version 10 and later.

Thanks much

The users.conf functionality has not been touched or changed. What happens when a device tries to register, what is the console output with sip set debug on?