Severe echo problem

I’m having severe problems with Echo. I’ve tried just about everything on and can’t seem to eleminate the problem.

This is my setup:

Current version of Asterisk, FreePBX and Zaptel running on via Epia/C3 500 box.
Digium TDM “Developer’s Kit” card with 1 FXS and 1 FXO. The FXS port is currently unused.

I have the FXO port connected to a Lucent ACS PBX system.
On my computer I have IAXComm softphone.

I dial the correct extension with IAXComm, get routed into the PBX which gives me an outside line, and hear the PBX Generated dial tone very clearly. I then dial my home phone number.

When I talk into the analog telephone I hear myself echoed very loudly with about a half second delay, and then about 6 echos with the standard echo volume decrease.

The headset I have connected to my computer does not hear the echo, and when I speak into the mic on the headset I don’t get echo.

I have tried recompiling the zaptel drives with various echo cancelers and I don’t seem to get any improvement. I’ve tried every setting I can find on voip-info and nothing seems to change.

Can anyone help me trouble shoot this?

Ok, Seems the problem is realted to there being no echo cancelling on the IAX Softphone… Is there a way around this or is there a softphone out there that will do echo cancelling?

The problem is not the softphone it is the FXO port. Stop asterisk but leave the Zaptel modules loaded and then run fxotume. Apply the fxotune settings and restart Asterisk. Echo on the calls using the PTSN should now have less echo.

See this page for more on fxotune: