More echo problems

Hey everyone

my setup, typical asterisk box with a x100p card. I am currently using asterisk 1.2.11 with zaptel 1.2.8. I had this setup and running fine with almost no echo, it was nice. i then upgraded asterisk to 1.2.12 and the echo hit like never before.
So i tried tweaking the zapata.conf file and use ztmonitor to get the gain set properly. i set it so both meters are as close to the middle as i can and still no change. zaptel is using MG2 echo canceller, also tried KB1 with no difference.
So then i tried rolling back to asterisk 1.2.11 and the echo still remains. no matter what i do nothing seems to even affect the echo at all.

anybody have any ideas to try?

try mark2 echo canceller with aggressive suppression enabled.

also try fxotune… that can help…

when you upgraded, it replaced your zap files. So it changed all your tuned settings for the PSTN. Do you have a backup of the files?

I did try a few of the echo cancellers. a question about them, do i need to reload the kernel modules after changing? or just restart asterisk… i did both (by rebooting, was easiest) and it didnt make a difference

which zap files are you talking? just zapata.conf or the moduels etc… like i said ive reinstalled zaptel (version 1.2.8, 1.2.9 wont compile for some reason) and restarted to reload the modules

dont know how to use fxotune, but i’ll read up on it and take a look

doenst seem fxotune will work on the x100p? am i correct? i stop asterisk and run fxotune -i 4 and its done within a second, not the minuted or two its supposed to take…

to set the echo canceller you must edit the (i think) zconfig.h file in the source code. then recompile/reinstall (make ; make install).

did that, rebooted to make sure the kernel modules were all loaded too.

I update the whole nine yards and got mine back to sounding right.
I got the echo when I went to 1.2.11 plus I was have off the hook issue(phone would answer but not release the line on hang up, which I never had before the asterisk only upgrade going to 1.2. 12 zaptel 1.2.9 fixed them both

I moved up to centos 4.4 and applied the lastest on everything
rebuilt zaptel
fxotune works fine on my X100P (real deal not knock off)