Service Unavailable 503

Good morning everyone, I’m new to Asterisk and I have a problem. I integrated Zabbix with Asterisk, so that an alert is generated in Zabbix, he makes a call via Asterisk informing me of such a problem. Everything is working perfectly with my internal extensions, but when I try to make external calls to the cell phone number, it fails. I have a SIP provider and I can connect to it, however, when my Zabbix generates the calls, the following errors appear:

  • Got SIP response 503 “Service Unavailable” back from IP-PROVIDER:5060
  • SIP/PROVIDER-0000000c is circuit-busy

Is there any idea what this could be? Maybe I forgot to configure something, I’m still a little new to Asterisk. If you want, I can make available my trunk settings and me sip.conf

503 is a catch all error. It is possible that the provider has included other headers giving more details, for which you would need to enable verbose logging and then use “sip set debug on”.

Note that chan_sip is effectively unsupported, and you should be making plans to use chan_pjsip. It will not be included in Asterisk 21. Which version of Asterisk are you using.

Good morning everyone, I’m new to Asterisk

Does this mean you have just set up a system of your own, or that you have
inherited an Asterisk system from someone else?

I integrated Zabbix with Asterisk

So, it sounds like you have set this system up…?

Is there any idea what this could be?

My guess is that you have not formatted the number to be dialled in a way your
external provider likes.

However, given the level of detail you have (not) provided, this is very much
a guess.

If you want, I can make available my trunk settings and me sip.conf

If this is a new system you are setting up, you really should not be using
sip.conf at all. chan_sip is deprecated and no longer maintained; you should
use chan_pjsip instead (you will also get a better quality of responses to
questions here as a result of doing that).

However, to help you diagnose the problem a bit further:

Can you make calls from something other than Zabbix (an internal extension,
for example) to this cellphone number?

If so, show us the logged output of a such a call, and also the logged output
of whatever Zabbix is doing which fails.

Also please tell us which version of Asterisk this is and what O/S it’s
running on.


also can you post the INVITE that asterisk is sending
(post is as text using the </> markup)

Hello everyone, I’m new to Asterisk in the sense that I’m starting to learn, but I installed a new system, the version is 13.15.0. I know maybe it’s a little outdated, but so far it’s serving me very well. I haven’t yet run tests from another source other than Zabbix, but I can try. About formatting the number, I tried it in two different ways, the most used here in my country (Brazil), and they gave me practically the same error. Could it be because I’m using chan_sip and not pjsip? I can enable debug and post here. As for the invite, I didn’t quite understand how to obtain it.

I installed a new system, the version is 13.15.0.

WHY ???

(That’s a genuine question - why did you choose Asterisk 13 as a version to
install in 2023?)

I know maybe it’s a little outdated

That’s an understatement - it was released nine years ago, there have been
eight major release versions since then, it went into “security fix only”
status three years ago, and has been completely unsupported for two years.

I think it would be irresponsible to provide you with assistance on getting a
new setup working with such an outdated version, because it will only make
your life more challenging into the future.

Come back to us when you are running Asterisk 18 or higher (I wouldn’t bother
with 19), and we’ll see what we can do to help.


PS: The above are my own personal opinions. Some people have others.

Hi set the caller I’d, this will solve your problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.