Running asterisk alongside web server please help

Hi I’m a complete beginner with asterisk and dahdi, but run a LAMP ubuntu deditcated server.

The server is for website hosting, email and cloud storage but I was told if I added a VOIP card I could also use it to take answer phone messages.

So I bought the pci card and added this to my server box…

Now I’m totally at a loss where to even start to set it up so it takes answer phone messages. The idea was it would answer the phone after 6 rings, say a message, take a voicemail then email me it. At least that was my plan.

On receiving the card the installation instructions always refer to existing pbx systems and don’t mention adding the card to an existing server already in use…

I tried a miss-mash of installing different bits from different guides but can’t get anything to work. I hoped someone could please guide me.

When I run lspci I get this:
04:00.0 Communication controller: Motorola Wildcard X100P

So at least the card is there. But when I run asterisk or go into the dahdi conf files (the ones I managed to find via guides but now I’m not sure where they are!) I only see a dummy soundcard/pci device and no mention of my x100p

I can run modprobe xcfxo and it highlights red and doesn’t give any output so I think the module loads.

As you can probably tell I’ve no idea how to get this setup going, any help would be really appreciated. Thanks!

ps I found the command which is showing my card isn’t loading up:

cat /proc/dahdi/*

Span 1: DAHDI_DUMMY/1 “DAHDI_DUMMY/1 (source: HRtimer) 1” (MASTER)

to install your card ask support for your vendor, which sell cloned old cards for digium so try with their guides and dont be surprised by the bad queality and the old drivers.

Said that you can take a look to “adding analog card to asterisk” in google or go to and install it. once you have the card upo and running you can create a simple dialplan like this pseudocode:

exten => s,1,Wait(5)
same => n,Answer()
same => n,Voicemail(VOICEMAILBOX,OPTIONS)

Hi thanks for the reply. I’ve tried contacting the vendor but still awaiting a reply… I wonder if any one else has used a x100p se card with ubuntu and can guide me just on how to get the card drivers installed?

Thanks again for any help.

Hi thank, just to update the thread.

After complaining to the vendor etc I didn’t receive a reply and found the card to be defective.

I ended up buying a different card which instead uses the wctdm24xxp module. This single port analog card works fine and I have now added this dialplan which works great for voicemail:


exten => s,1,Wait(1)
exten => s,n,Answer
exten => s,n,Playback(customrecording)
exten => s,n,Voicemail(1111,s)

The ,s on the end of the mailbox number skips the extension/mailbox playback messages so people calling only get the initial Playback message.

I also then had to define the 1111 mailbox in voicemail.conf too like this:


1111 => 4242,MyName,,,delete=yes

with ,delete acting to delete a mailbox recording from var/spool/asterisk/voicemail folder once it has been emailed!

Just testing it out, but it seems to work great. I wanted to post this here so anyone else attempting this might be able to set it up and for a record for me in the future too!

As for the x100p SE card, it will probably end up in the bin!

Thanks again for your help.

1 Like