Moved server - dahdi no longer works

Hi all,

I’ve recently migrated my Asterisk server from the old desktop it was running on to a proper server (HP DL380). I predominently use VoIP, but have a single Wildcard X100P card for PSTN fallback. Everything migrated OK from a VoIP perspective, and once I was satisfied that the new server was OK I decommission the old one and moved the X100P card to the DL380.

My problem is that the X100P card is not working, even though the config is exactly the same as the old server. If I run lspci I can see the card listed (03:01.0 Communication controller: Motorola Wildcard X100P), and dahdi_hardware reveals the card (pci:0000:03:01.0 wcfxo- 1057:5608 Wildcard X100P), but if I run dahdi_cfg I get “DAHDI_CHANCONFIG failed on channel 1: No such device or address (6)”.

My system.conf is:

fxsks=1 loadzone=uk defaultzone=uk echocanceller=mg2,1

My modules is:

[code]# Digium TE205P/TE207P/TE210P/TE212P: PCI dual-port T1/E1/J1

Digium TE405P/TE407P/TE410P/TE412P: PCI quad-port T1/E1/J1

Digium TE220: PCI-Express dual-port T1/E1/J1

Digium TE420: PCI-Express quad-port T1/E1/J1


Digium TE120P: PCI single-port T1/E1/J1

Digium TE121: PCI-Express single-port T1/E1/J1

Digium TE122: PCI single-port T1/E1/J1


Digium T100P: PCI single-port T1

Digium E100P: PCI single-port E1


Digium TE110P: PCI single-port T1/E1/J1


Digium TDM2400P/AEX2400: up to 24 analog ports

Digium TDM800P/AEX800: up to 8 analog ports

Digium TDM410P/AEX410: up to 4 analog ports


X100P - Single port FXO interface

X101P - Single port FXO interface


Digium TDM400P: up to 4 analog ports


Digium B410P: 4 NT/TE BRI ports


Digium TC400B: G729 / G723 Transcoding Engine


Xorcom Astribank Devices


If I run dahdi_tool I can only see one entry for DAHDI_DUMMY.

Any pointers as to how to get this card recognised?


The X100P is a rather old card. Perhaps your new hardware’s BIOS just doesn’t recognize it. Try moving it to another slot. If that does not work buy one of the newer cards. You could probably run this down with HP but it will probably take quite some time.

Sometimes it’s easier to throw money at a problem and save the effort.

I’m not sure it’s a hardware problem as no log file indicates an error and dahdi_hardware picks it up OK…?

Could the problem be that I physically installed the card after I compiled & installed dahdi?