[RESOLVED] Inbound sipgate calls are bouncing

Hi folks

Round 4 here for me, and hopefully this time I picked the right starting point. Now running my dedicated box on Ubuntu server, with Asterisk installed using apt-get, and asterisk-gui according the recipies floating around. All seems to be working at that level.

[quote=“the Asterisk-gui status screen”]OS Version:
Linux PhoneBox 2.6.28-11-server #42-Ubuntu SMP Fri Apr 17 02:45:36 UTC 2009 x86_64 GNU/Linux

Asterisk Build:
Asterisk/1.4.21.2~dfsg-3ubuntu2
Asterisk GUI-version : SVN-branch-2.0-r4980[/quote]
I’m on a Virgin Media (ex-NTL) cable modem, with an OpenWRT router between that and everything else. Ports 5004, 5060, 8000-8012 and 10000-20000 are forwarded direct to the Asterisk box.

My sipgate line is configured as a trunk, reported in Asterisk-gui as “Registered”, and by sipgate as “online”.

My Grandstream Budgetone 100 phone is set up as extension 6000, as a SIP/IAX user, with the IP of my server as its provider, and is reported by Asterisk-GUI as online and free.

I have an outgoing call rule of “0!” which (hopefully) allows any number with a zero at the start to be passed across to the trunk (with the removal of the first digit) - my intention here is “dial zero to get an outside line”.

I have an incoming calling rule with a pattern of “s” which (again, I hope) passes all inbound calls to extension 6000.

But I seem to have missed something. Inbound external calls to the sipgate number get an engaged tone, and dialing 010000 gives a 404. What I’d hoped for with 010000 was the standard sipgate test message “your phone is now configured correctly”.

Note that I haven’t delved into the conf files yet, all setup so far has been via the GUI. Hoping to keep it that way, am I being over-optimistic? I think that setting up the awful Nortel UNIstim-only phone might need me to get the spanners & blowtorch out, so I’ll leave that til last!

What did I miss?

update

have added a UTstarcom F1000G into the mix, it’s also up & running. The extensions can call each other quite happily, but still no connection to the outside world.

There must be something really simple that I’ve overlooked or misconfigured. Help!

and a bit more info…

if I reconfigure a phone to log directly on to sipgate, completely bypassing my Asterisk box, it works just fine, can receive BT-originated calls etc. I didn’t even reconfig the router’s port-fowards, and it STILL worked.

I’ve Googled this to death, been through the (minimal) info on the sipgate site, not sure what else to try and would really appreciate a nudge in the right direction. Somebody please point out the blindingly obvious?

…and a bit more:

I think I might be missing the "register => " line in sip.conf (yes, I’ve finally climbed into the conf files). Going to try that next, but I’m a little scared of it. I plan to have three or four sipgate lines eventually, not sure how to do multiple registrations. But I guess I’ll cross that bridge later.

OK, that didn’t seem to make any difference at all, I’m guessing the GUI sorts this out elsewhere?

delving a little deeper, the logs show me what happens when an internal call hits the Asterisk box:

the only things this tells me is that it’s configured half-right, as the call is at least reaching my server.

Now what?

(talking to myself here) :laughing: hoping we’ll eventually get to a resolution and the copious notes may later prove useful to somebody else.

Poking around the .conf files, I came across this at the bottom of users.conf:

[quote][trunk_1]
host = sipgate.co.uk
username = MySipgateID
secret = YeahRight
trunkname = sipgate ; GUI metadata
context = DID_trunk_1
group = null
hasexten = no
hasiax = no
hassip = yes
registeriax = no
registersip = yes
trunkstyle = voip
insecure = port
fromuser = MySipgateID
outboundproxy = sipgate.co.uk
authuser = MySipgateID:YeahRight@sipgate.co.uk/MySipgateID
disallow = all
allow = ulaw,alaw,gsm,g726
[/quote]
It’s that second-last line that’s bothering me…

oooooh… in that users.conf above… am I missing a “type = peer” or something? Rings a bell from the docs I’ve read…

OK that was a red herring too… tried both “type = peer” and “type = friend”, makes no difference.

Where do I look next?

wheeeee!

Flaming GUI getting in the way!

picking apart my users.conf file with tweezers and a microscope, it occurred to me that the [trunk_1] section was missing a couple of bits. Turns out the critical one was

once that was in place, external calls to my sipgate number came straight through, and the phone on my desk rang. RESULT!

Now I can start with the REAL fun, adding more extensions, wrestling with the Nortel UNIstim unit, looking at fax-receipt capabilities, etc.