Simple setup, once incoming sipgate line, one extension

This is turning out to be a lot harder than I thought it would.

Running under Fedora 11. Asterisk installed OK and can be used in command-line mode. The service appears to be running. I tried (and tried and tried) to get the Asterisk GUI going to no avail. Everything seems to have installed OK, but it’s just never there when I browse to it. Have (for now anyway) given up on the GUI, my setup is so simple it shouldn’t really be an issue. I’ve spent two days wading through documentation, how-to guides and instructions and I still don’t seem to be connecting the dots.

So now I’m asking for help.

I have a SipGate account, tested and working with a soft-phone. I want Asterisk to take over the management of that line for me, then pass through any incoming calls to a Nortel phone - unfortunately one of the UNIStim-only ones.

I don’t need to make outgoing calls via the system yet.

In the future I’ll look at adding more phones, to set up a simple home exchange, but right now I just want to get this working!

How hard can this really be? Where did I miss the one proper “Asterisk for Dummies” single-page how-to that will lead the way?

I have a SipGate account working nicely with Asterisk. Did you follow their configuration example? I took my config pretty much directly from this page and it worked first time.

You have to configure your Asterisk to connect TO SipGate as as if you want to place outgoing calls, this tells the SipGate server about your server and consequently the SipGate server knows where to route calls to you.


Still getting nowhere fast here…

I’ve switched Asterisk off and connected the softphone direct to SipGate. Worked perfectly. So I know that much at least is good. Putting the pieces back together…

my sip.conf:[code]

register =>

callerid=“etalk” <8081>[/code]

The Asterisk box runs on IP, under Fedora 11.

The softphone has been set up to match the above, but never manages to register with the server. Running an Asterisk console with -vvvvvvvvvr doesn’t show any activity on the connection attempt.

What did I miss? Or should I just junk the whole lot and try again with AsteriskNOW?

OK, I gave up, trashed it completely and installed AsteriskNOW.

First off… no UNIStim support on this?

ANd secondly… I still can’t get a flaming phone to register. AAAAaaargh, going to bed now, will play some more at the weekend.


Probably a moot point now that installation is gone, but in your posted sip.conf you also need a section for the outgoing sipgate peer (in addition to the register => statement).

If you have set up your softphone to register with your Asterisk server on the standard SIP port, and even with SIP debugging on (type ‘sip debug’ from the console) you get no activity on the console then it suggests that the registration requests are not reaching Asterisk. In which case I would suspect a firewall issue. Some linux distos seem to come with an active firewall that can get in the way. I’ve never tried either AsteriskNOW or Fedora so can’t be specific.