SIP trunk connection problem


#1

Hi, just tried to get a connection working with SipGate.co.uk

I can’t call out and can’t call in. In asterisk console -rvvvvvvv it prints this when I try and make an external call:

== Using SIP RTP CoS mark 5 -- Executing [01432359481@phones:1] Set("SIP/101-0000002b", "CALLERID(num)=1323230") in new stack -- Executing [01432359481@phones:2] Dial("SIP/101-0000002b", "SIP/01432359481@sipgate,30,trg") in new stack == Using SIP RTP CoS mark 5 -- Called 01432359481@sipgate -- SIP/sipgate-0000002c is circuit-busy == Everyone is busy/congested at this time (1:0/1/0) -- Executing [01432359481@phones:3] Hangup("SIP/101-0000002b", "") in new stack == Spawn extension (phones, 01432359481, 3) exited non-zero on 'SIP/101-0000002b

When I try and call in, it does not even show anything in the console

sip show peers:

Name/username Host Dyn Nat ACL Port Status 100/100 192.168.1.238 D 5060 Unmonitored 101/101 192.168.1.160 D 56559 Unmonitored sipgate/1323230 204.155.28.10 5060 OK (210 ms) 3 sip peers [Monitored: 1 online, 0 offline Unmonitored: 2 online, 0 offline]

extentions.conf:

[code][globals]

[general]

[default]
exten => s,1,Verbose(1,Unrouted call handler)
exten => s,n,Answer()
exten => s,n,Wait(1)
exten => s,n,Playback(tt-weasels)
exten => s,n,Hangup()

[incoming_calls]
exten => 1323230,1,Dial(SIP/100)
exten => 1323230-ID,n,Hangup

[outgoing_calls]
exten => _X.,1,Set(CALLERID(num)=1323230)
exten => _X.,2,Dial(SIP/${EXTEN}@sipgate,30,trg)
exten => _X.,3,Hangup

[internal]
exten => 100,1,Verbose(1,Extention 100)
exten => 100,n,Dial(SIP/100,30)
exten => 100,n,Hangup()

exten => 101,1,Verbose(1,Extention 101)
exten => 101,n,Dial(SIP/101,30)
exten => 101,n,Hangup()

[phones]
include => internal
include => outgoing_calls[/code]

sip.conf:

[code]
[general]
context=default
bindport=5060
srvlookup=yes

[100]
type=friend
context=phones
host=dynamic
secret=*********

[101]
type=friend
context=phones
host=dynamic
secret=*********

register => 1323230:@sipgate/1323230
[sipgate]
type=peer
secret=

insecure=invite
username=1323230
defaultuser=1323230
fromuser=1323230
context=incoming_calls
fromdomain=sipgate.com
host=sipgate.com
outboundproxy=proxy.live.sipgate.com
qualify=yes
disallow=all
allow=ulaw
dtmfmode=rfc2833[/code]

And help or pointers, I would be happy :smiley:


#2

If sipgate.com (SIPGATE US) is correct, than the dialing format should be NANP-format, that means You should dial either 10digits US-numbers or international (Non-US-Numbers) as 011.
But as You’re writing, You’re trying to use SIPGATE UK. For this one the dialing format (within UK) is correct, but the peer definition is not.
It should work with sipgate.co.uk instead of sipgate.com, outboundproxy is AFAIK not needed:

register => 1323230:********@sipgate/1323230 [sipgate] type=peer secret=******** insecure=invite username=1323230 defaultuser=1323230 fromuser=1323230 context=incoming_calls fromdomain=sipgate.co.uk host=sipgate.co.uk qualify=yes disallow=all allow=ulaw dtmfmode=rfc2833


#3

[quote=“abw1oim”]If sipgate.com (SIPGATE US) is correct, than the dialing format should be NANP-format, that means You should dial either 10digits US-numbers or international (Non-US-Numbers) as 011.
But as You’re writing, You’re trying to use SIPGATE UK. For this one the dialing format (within UK) is correct, but the peer definition is not.
It should work with sipgate.co.uk instead of sipgate.com, outboundproxy is AFAIK not needed:[/quote]

Hmm, still getting this when calling out. Still nothing on call in :confused:

== Using SIP RTP CoS mark 5 -- Executing [07757416168@phones:1] Set("SIP/100-00000004", "CALLERID(num)=1323230") in new stack -- Executing [07757416168@phones:2] Dial("SIP/100-00000004", "SIP/07757416168@sipgate,30,trg") in new stack == Using SIP RTP CoS mark 5 -- Called 07757416168@sipgate -- SIP/sipgate-00000005 is circuit-busy == Everyone is busy/congested at this time (1:0/1/0) -- Executing [07757416168@phones:3] Hangup("SIP/100-00000004", "") in new stack == Spawn extension (phones, 07757416168, 3) exited non-zero on 'SIP/100-00000004'


#4

Is Your account topped up? (relevant for outgoing calls)
Please provide the debug output (sip set debug peer sipgate) when issuing an outgoing call and afterwards when issuing an inbound call.


#5

Chnaged my provider to Soho66, but the same problem again…

[code]<------------->
— (8 headers 0 lines) —

<— SIP read from UDP:84.45.53.115:5060 —>
SIP/2.0 603 Declined
Via: SIP/2.0/UDP 192.168.1.48:5060;received=192.168.1.48;branch=z9hG4bK3299230c;rport=61723
From: “101” sip:1000011418@192.168.1.48;tag=as4adb02de
To: sip:08458622624@sip.soho66.co.uk;tag=as6db6b135
Call-ID: 1dc8a32803b2b0a946f386dd571f2cd4@192.168.1.48
CSeq: 102 INVITE
User-Agent: AsterSoho66
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY
Supported: replaces, timer
Contact: sip:08458622624@84.45.53.103:5061
Content-Length: 0
X-LastSIPResponseCode: 603
X-LastSIPResponseReason: Declined

<------------->
— (13 headers 0 lines) —
– Got SIP response 603 “Declined” back from 84.45.53.115
Transmitting (NAT) to 84.45.53.115:5060:
ACK sip:08458622624@sip.soho66.co.uk SIP/2.0
Via: SIP/2.0/UDP 192.168.1.48:5060;branch=z9hG4bK3299230c;rport
Max-Forwards: 70
From: “101” sip:1000011418@192.168.1.48;tag=as4adb02de
To: sip:08458622624@sip.soho66.co.uk;tag=as6db6b135
Contact: sip:1000011418@192.168.1.48
Call-ID: 1dc8a32803b2b0a946f386dd571f2cd4@192.168.1.48
CSeq: 102 ACK
User-Agent: Asterisk PBX 1.6.2.9-2+squeeze3
Content-Length: 0


-- SIP/sip.soho66.co.uk-00000015 is busy

== Everyone is busy/congested at this time (1:1/0/0)
– Executing [08458622624@phones:3] Hangup(“SIP/101-00000014”, “”) in new stack
== Spawn extension (phones, 08458622624, 3) exited non-zero on 'SIP/101-00000014’
Really destroying SIP dialog ‘1dc8a32803b2b0a946f386dd571f2cd4@192.168.1.48’ Method: INVITE
Reliably Transmitting (NAT) to 84.45.53.115:5060:
OPTIONS sip:sip.soho66.co.uk SIP/2.0
Via: SIP/2.0/UDP 192.168.1.48:5060;branch=z9hG4bK37094439;rport
Max-Forwards: 70
From: “asterisk” sip:asterisk@192.168.1.48;tag=as0df64cc1
To: sip:sip.soho66.co.uk
Contact: sip:asterisk@192.168.1.48
Call-ID: 4c0e196b22f895115889479553b33d04@192.168.1.48
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX 1.6.2.9-2+squeeze3
Date: Mon, 19 Sep 2011 14:22:47 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0


<— SIP read from UDP:84.45.53.115:5060 —>
SIP/2.0 484 Address Incomplete
Via: SIP/2.0/UDP 192.168.1.48:5060;branch=z9hG4bK37094439;rport=61723
From: “asterisk” sip:asterisk@192.168.1.48;tag=as0df64cc1
To: sip:sip.soho66.co.uk;tag=02dda189045d8d9d3c03c62edbe63306.6fe0
Call-ID: 4c0e196b22f895115889479553b33d04@192.168.1.48
CSeq: 102 OPTIONS
Server: OpenSIPS (1.5.2-notls (x86_64/linux))
Content-Length: 0

<------------->
— (8 headers 0 lines) —
Really destroying SIP dialog ‘4c0e196b22f895115889479553b33d04@192.168.1.48’ Method: OPTIONS
Reliably Transmitting (NAT) to 84.45.53.115:5060:
OPTIONS sip:sip.soho66.co.uk SIP/2.0
Via: SIP/2.0/UDP 192.168.1.48:5060;branch=z9hG4bK03a050fa;rport
Max-Forwards: 70
From: “asterisk” sip:asterisk@192.168.1.48;tag=as760e1870
To: sip:sip.soho66.co.uk
Contact: sip:asterisk@192.168.1.48
Call-ID: 02b223f33b8bc4b17095add561794921@192.168.1.48
CSeq: 102 OPTIONS
User-Agent: Asterisk PBX 1.6.2.9-2+squeeze3
Date: Mon, 19 Sep 2011 14:23:47 GMT
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO
Supported: replaces, timer
Content-Length: 0


<— SIP read from UDP:84.45.53.115:5060 —>
SIP/2.0 484 Address Incomplete
Via: SIP/2.0/UDP 192.168.1.48:5060;branch=z9hG4bK03a050fa;rport=61835
From: “asterisk” sip:asterisk@192.168.1.48;tag=as760e1870
To: sip:sip.soho66.co.uk;tag=02dda189045d8d9d3c03c62edbe63306.2abd
Call-ID: 02b223f33b8bc4b17095add561794921@192.168.1.48
CSeq: 102 OPTIONS
Server: OpenSIPS (1.5.2-notls (x86_64/linux))
Content-Length: 0

<------------->
— (8 headers 0 lines) —
Really destroying SIP dialog ‘02b223f33b8bc4b17095add561794921@192.168.1.48’ Method: OPTIONS
[/code]


#6

Where are your externhost, externip or STUN settings?


#7

Right, yes, umm, have not looked into that yet. I’m guessing now this is a firewall problem :confused: Why is SIP so annoying??