Remove "Please leave a message..." for specific extensions

Hi guys,
I need to remove the automatic message “Please leave a message after the tone…” after the user’s message, but only for specific extensions, not for all of them. I found some information so far, regarding to the “s”/“su” options, but it’s not clear where (in which file) and how to add this information. And actually what kind of commands to add. For example for extension 3011. Help me please!

Take a look on this … +VoiceMail

Thank you,
I know this document, but it doesn’t make sense for me. I don’t have so deep knowledge with the Asterisk. BTW, I’m using it with Trixbox, but it suppose to be the same.
If somebody know how, please lets give me the exact command lines and location. Just one extension: 3011.
Thanks in advance!

The bit you are asking about is part of the added value in Trixbox. Asterisk, itself, doesn’t come with any production dial plans.

Maybe you dont want to take a deeper look on it its very transparent the information there:

Leave a voicemail message in one or more mailboxes.




But if you are using trixbox(eww) you need to do it via the GUI go to the voicemail settings. As trixbox is very deprecated i dont know where but in Freepbx you go to the Extensions settings and find VMXlocater and uncheck the option Standard Voicemail prompts. Or go to Optional Destinations And select Voicemail no-msg option.

Thanks Navismo,
It works just perfect but on Elastix (latest version, I like it!). I cannot even find the FreePBX on the Trixbox ( v. Maybe this version doesn’t have FreePBX or what?