[Resolved] Direct-dial to voicemail bypasses Unavailable msg

Hey, I’m guessing there’s a simple answer to this. I’m quite new to Asterisk however, and not sure exactly what the syntax & possibilities are with Extensions.conf.

Currently, if someone here dials *EXT, they go directly to the voicemail for EXT (EXT being a 3-digit extension). That’s great. You can even transfer incoming callers to voicemail the same way… but those people end up confused, because instead of hearing the person’s recorded unavailable message, they just get the stock “Please leave your message after the tone” bit.

In Extensions_additional.conf, (#included by extensions.conf)
I have:
Is that what’s making this happen? Is there a way to use those fun priority schemes to make this behave more rationally? I just want them to enter voicemail as if they have waited for it to pickup without having to wait for it to pickup…

Let me know if I’ve given incomplete information, and I’ll post whatever is needed.

Thanks for your help!

oh the joys of FreePBX :open_mouth:

somewhere in the extensions_xxx files is a section with _${VMPREFIX} extensions. find that, and post it here.

i use something probably similar : ; Direct-to-VoiceMail exten => _${VM_PREFIX}2XX,1,VoiceMail(${EXTEN:1}|ug(5)) exten => _${VM_PREFIX}2XX,2,Macro(hangupcall)

i expect the TrixBox version is much more complicated.

You’re quite right, it’s way more complicated on Trixbox. In “extensions_additional.conf”

include => ext-local-custom
exten => 199,1,Macro(exten-vm,novm,199)
exten => 199,hint,SIP/199
exten => 200,1,Macro(exten-vm,200,200)
exten => 200,hint,SIP/200
exten => ${VM_PREFIX}200,1,Macro(vm,200,DIRECTDIAL)
exten => 201,1,Macro(exten-vm,201,201)
exten => 201,hint,SIP/201
exten => ${VM_PREFIX}201,1,Macro(vm,201,DIRECTDIAL)

Etc for all my extensions. It looks like TrixBox is writing these in each time I create a new extension?

I suspect I should get rid of these and do something more like what you’ve got, right? Only how do I stop TrixBox from writing these things in and overriding? Question for the Trixbox people?

Thanks for your help!


I resolved this problem, which was a trixbox/freepbx issue, with advice found here:
trixbox.org/modules/newbb/vi … 55&forum=2

In the FreePBX web interface, under Setup -> General Settings you’ll see a drop-down for “Direct Dial to Voicemail message type:” That will fix your problem and, like me, you’ll feel a little foolish for not finding it on your own. But you know what? It doesn’t really feel like a “General Setting” to me either. What a weak category!