Queue + 1.4.2 + moh silent when not speaking

Hi everyone,

Just managed to get Queues working good in asterisk 1.4.2 (never knew about them before, great functionality!).

Having a really weird problem though, when I dial the Queue from an external phone (incoming through SIP trunk to the asterisk box) the music on hold can ONLY be heard when I make noise into the phone, as soon as I stop making noise I stop hearing the music on hold, then I start making noise again and I can hear the music on hold again.

This is very odd because playback() and background() both play fine in the same situation when i’m not making any noise.

If I dial the queue from an internal SIP extension there is no issue.

Incoming SIP trunk that exhibits this problem:

[enginin] type=user fromdomain=voice.mibroadband.com.au host=mel.byo.engin.com.au username=0884640161 secret=******* context=default canreinvite=yes insecure=port,invite

Log of what happened when queue was dialed through SIP trunk:

-- Executing [0884640161@default:1] Ringing("SIP/", "") in new stack -- Executing [0884640161@default:2] Wait("SIP/", "1") in new stack -- parse_srv: SRV mapped to host sip.internode.on.net, port 5060 -- Executing [0884640161@default:3] Answer("SIP/", "") in new stack -- Executing [0884640161@default:4] Playback("SIP/", "corra-welcome") in new stack -- <SIP/> Playing 'corra-welcome' (language 'en') [Apr 21 19:29:32] NOTICE[37284]: rtp.c:783 process_rfc3389: Comfort noise support incomplete in Asterisk (RFC 3389). Please turn off on client if possible. Client IP: -- Executing [0884640161@default:5] Queue("SIP/", "corra|t|||50") in new stack -- Started music on hold, class 'default', on SIP/ -- SIP/enginout-08763000 is ringing [Apr 21 19:29:45] NOTICE[37284]: rtp.c:783 process_rfc3389: Comfort noise support incomplete in Asterisk (RFC 3389). Please turn off on client if possible. Client IP: -- Nobody picked up in 50000 ms -- Stopped music on hold on SIP/

bump any ideas anyone?



I have the same issue, but with GSM codec only. When I changed the codec to u-law, or a-law, MOH plays normally…
Anybody any more hints???

I have problems with MusicOnHold on Asterisk 1.2.17 too.It suddenly stops for sec or two and continues after that.Like music cutting.The problem occures no meter what codec I use (tried ulaw alaw gsm or ilbc).

Sorry for bad english.

I have same problem then creating Queue with MOH. Problem was resolved by turning off VAD (voice activity detection) on my gateway (Cisco AS5350). Try it, maybe it helps.

Thanks for the tips everyone. I tried turning off GSM and that didn’t help. My gateway is an SIP provider so I cannot turn off VAD. I’ve done a bit of searching and found this:

lists.digium.com/pipermail/aster … 26191.html

I fixed my problem by using those instructions but they were slightly wrong.

In asterisk.conf uncomment the following lines:

internal_timing = yes

I also modified the zaptel startup script to ztdummy.ko from the installed zaptel port (im using freebsd),

This solved my problem. Thanks for everyones help.

That internal timing did not solve my problem.I wonder can Asterisk work with digium 1 span isdn pri card,one on board eth0 (for LAN) and another eth1 for WAN ? zttest gave me the lowest result of 99.890137 . [color=red] And I read that digium beast needs 1000 interrupts per second and if number falls bellow 99.987 problems can come but if number falls bellow 99.975 problem will come for sure.Is my problem connected with interrupts ?
Would router solve that problem ? (all computers from LAN will be connect to router and router will be connect to optical cable (WAN) so eth1 will go out and free interrupts)[/color] I turned off all unnecessary services on Fedora Core 6 as well as in BIOS (sound card,usb and there is no irq sharing).

If I introduce that router I guess my server will be behind NAT for WAN users so I would appreciate if you could tell me link with how to connect WAN SIP operators to Server behind nat (I know for port forwarding for sip and rtp but I had strange problem that oprator can register on server (nat=yes and nat=no account) and can hear first message during AgentLogin process but after that his XLite seems to be dead and he can not enter password and I can see max try exceeded warning on CLI Do I need to set STUN on Xlite ? )