MOH Silence in 1.6

My first post here - So Hi All :smiley:

I must say that Asterisk is a brilliant product but I’m having a hell of a time getting MOH to work.

Out of the box, the WAV’s will not play so I tried MP3’s

I’ve installed mpg123 and from what I can see EVERYTHING is good but I do not get any sound on the phone.

CLI Log reads:

- Called 1001 -- SIP/1001-09c37138 is ringing -- SIP/1001-09c37138 answered SIP/1002-09c41880 -- Native bridging SIP/1002-09c41880 and SIP/1001-09c37138 -- Started music on hold, class 'default', on channel 'SIP/1001-09c37138' MANUALLY HANG UP HERE -- Stopped music on hold on SIP/1001-09c37138 == Spawn extension (default, 1001, 1) exited non-zero on 'SIP/1002-09c41880'

So the above looks good.

I can play MP3’s and hear them with exten => 9001,2,MP3Player(/tmp/mymp3sample.mp3) so mpg123 is working.

I also see this in the process list:

15352 pts/0 Sl+ 0:00 asterisk -vvvvc 15361 pts/0 S+ 0:01 mpg123 -q -s --mono -r 8000 -b 2048 -f 8192 mymp3sample.mp3 15363 pts/0 S+ 0:00 mpg123 -q -s --mono -r 8000 -b 2048 -f 8192 mymp3sample.mp3 15387 pts/1 R+ 0:00 ps ax

So I guess that the MP3 is playing in the background and all looks good.

So why can’t I hear anything on the phone when either in “On Hold” mode or with exten => 9000,2,MusicOnHold(20)

I’ve been Googling for the last 2 days and I know quite a lot about MOH but I simply cannot get this to work.

Oh and my version of Asterisk is latest: 1.6.0.3 (from source) and the server does NOT have a sound card.

Anybody have any ideas on what I can try next?

Cheers,
Andy

I think this is a bug in 1.6.0.3.

If I add a playback before Dialing the extension, it works perfectly

This works:

exten => 1001,1,playback(afternoon) exten => 1001,2,Dial(SIP/1001,30) exten => 1001,3,voicemail(1001,u)

This does not:

exten => 1001,1,Dial(SIP/1001,30) exten => 1001,2,voicemail(1001,u)

I tried adding a 2 second delay before Dialing but that didn’t work either.

Hi,

Can anybody confirm that this is a bug or not?

Cheers,
Andy

Hi

When you compiled Asterisk it will have put the default Music onhold files in the directory defined , This will be wav format.

I think you need to get streaming music on hold working, post your musiconhold conf file so we can see whats set up

Ian

If SLIN doesn’t work I really wouldn’t expect MP3 to work, as it needs to be converted to SLIN anyway.

You have a report of native bridging. I’m not sure whether the start music on hold implies that native bridging has been undone. It might be worth using SIP history or SIP debug to determine whether the call has been re-invited back. If it hasn’t been re-invited back, you have a bug.

What did you do to initiate the hold?

[quote=“milonic”]Hi,

Can anybody confirm that this is a bug or not?

Cheers,
Andy[/quote]

I can’t confirm if this is a bug in Asterisk but after last reboot I observe similar behaviour in my installation. I have followed suggestion of placing Playback(silence/1) which somehow initiates playback engine and MOH can be heard again.