Queue No Sound at all when inbound call

i have such problem if incoming call comes from trunk there is no sound in queue (but if i make in extensions.con playback(hello-world) it is playing it and i can hear it)
only problem is in queue. but if i am calling from internal extension to queue there is sound (i mean moh and possition announcment) here is my queue.conf file

[general]
persistentmembers=yes
autofill=yes
monitor-type=MixMonitor
shared_lastcall=no;

[333]
announce-frequency=5
announce-holdtime=no
announce-position=yes
autofill=no
autopause=no
autopausebusy=no
autopausedelay=0
autopauseunavail=no
joinempty=yes
leavewhenempty=no
maxlen=0
memberdelay=0
min-announce-frequency=300
penaltymemberslimit=0
periodic-announce-frequency=0
queue-callswaiting=hello-world
queue-thankyou=hello-world
queue-thereare=hello-world
queue-youarenext=hello-world
reportholdtime=no
retry=15
music=default
ringinuse=yes
servicelevel=60
setinterfacevar=yes
strategy=linear
timeout=5
timeoutpriority=app
timeoutrestart=no
weight=0
wrapuptime=0
context=inb
member=> SIP/100,1
member=> SIP/101,2

and here is my extensions.con

[public]
include => inb
[inb]
inculde=> public
;exten => _777,1,Playback(hello-world)
exten => _777,1,Queue(333)
can you tell me what is problem iptables is disabled

A few things maybe. First you have a typo:

inculde=> public

Should be:

include=> public

There is no “music” option, but “musicclass”. Although I believe it should default to using MOH without it.

Lastly, I’m not seeing anywhere where you answer the call. So might need something like the following:

exten => _777,1,Noop()
same => n,Answer()
same => n,Queue(333)
same => n,Hangup()

If you’re still having problems set the debug and verbose levels in Asterisk to at least 5 and post the relevant log when you try to make a call.

Queue will send annoucements etc. as early media if the call is not already answered. Most service providers will reject early media because it can be used for free calls. Asterisk may require Progress () to be called for it to work even if the upstream supports it.

big thnx for help it realy helped me out