Problems with Asterisk 1.4 and Broadvoice

I’ve been using Asterisk 1.4 (first beta releases, eventually the release version) with Broadvoice for a few months, and it’s been working fine. However, for the last few days, calls to the Broadvoice number ring through, but get disconnected when answered, because Asterisk can’t send SIP messages to Broadvoice. I tried several proxies, all with the same result.

I’m typing this as I’ve been holding for almost an hour with them…

Has anyone seen this problem?

Asterisk has no problem registering, and placing calls. It’s the answering that’s broken…



There is nothing wrong with Broadvoice. I use them and have not encountered any issues recently. The service is flawless. You need to check your config on answering or perhaps its an * 1.4 issue, I have not used 1.4 yet but every version I upgrade to all I have to do is install and copy all my files into it then start asterisk and off it goes. I would say check your * installation, or if you can post your extensions.conf that might help.


There is nothing wrong with Broadvoice.[/quote]

There was, actually, they eventually answered the phone, I explained the problem to the tech, I heard some furious typing, then he asked me to “try again”. I relaoded SIP, and all is well.


I have gone through something similar in the past where it seems that the proxy I am closest to is choked up and not allowing a register, so I try another and I am good to go. But I was just trying the process of elimination, to say that since I use Broadvoice and there has been no problem then it might not be their end. Good thing you are good to go now.