Problem with parked calls, connection but no sound

I have spend hours trying to figure out why I can’t get a parked call back by calling 701. I have been testing and it worked once after updating zaptel and asterisk to the latest 1.2 versions. After that one call the problem started again.

I use Idefisk 1.35 for mac and I also tried Loudhush as the softphone. Same problem.

The server has a public IP and the softphone is behind nat but works fine for the rest. I can make calls, transfer calls etc. When I call the server with my cellphone the call is transfered to a queue. I logged into the queue with idefisk and that works fine. I park the call dialing 700 and that works fine too, cellphone has moh and idefisk is disconnected. Then I dial 701 with idefisk to get the call back. The connection is there but there is no sound at all.

This is the cli output that looks pretty normal to me:

Accepting AUTHENTICATED call from
> requested format = alaw,
> requested prefs = (),
> actual format = alaw, (gsm when I use my cellphone)
> host prefs = (alaw),
> priority = mine
– Executing Dial(“IAX2/erik-9”, “IAX2/Voopxxxxx@voop/3106xxxxxxxx|20|rt}”) in new stack
– Called Voopxxxxx@voop/3106xxxxxxx
– Call accepted by (format alaw)
– Format for call is alaw
– IAX2/voop-10 is proceeding passing it to IAX2/erik-9
– IAX2/voop-10 is ringing
– IAX2/voop-10 answered IAX2/erik-9
== Spawn extension (intern, 06xxxxxxxx, 1) exited non-zero on ‘IAXPeer/IAX2/erik-9’
– Started music on hold, class ‘default’, on channel ‘IAX2/voop-10’
== Parked IAX2/voop-10 on 701. Will timeout back to extension [intern] s, 1 in 45 seconds
– Added extension ‘701’ priority 1 to parkedcalls
– Playing ‘digits/7’ (language ‘en’)
– Playing ‘digits/0’ (language ‘en’)
– Playing ‘digits/1’ (language ‘en’)
– Hungup 'IAX2/erik-9’
May 6 01:39:51 NOTICE[14952]: chan_iax2.c:6262 iax_park_thread: Parked on extension ‘701’
– Accepting AUTHENTICATED call from
> requested format = alaw,
> requested prefs = (),
> actual format = alaw,
> host prefs = (alaw),
> priority = mine
– Executing ParkedCall(“IAX2/erik-6”, “701”) in new stack
– Stopped music on hold on IAX2/voop-10
– Channel IAX2/erik-6 connected to parked call 701

This is the output of "show channels"
IAX2/erik-12 701@intern:1 Up ParkedCall(701)
IAX2/Voopxxxxx-4 02xxxxxxxx@intern:1 Up Bridged Call(IAX2/erik-12)
2 active channels
1 active call

This is the extesions.conf part. It is included into extensions.conf and show up with “show dialplan” so it must be in place.

exten => 020xxxxxxx,1,Queue(020xxxxxxx,tT)

this is the part to login and logout of the queue:
exten => 01login,1,Macro(queuelogin|020xxxxxxx)
exten => 01logout,1,Macro(queuelogout|020xxxxxxx)

this is the part in queues.conf that enables every internal phone to log in to the queue
member => Agent/_.

This are the login and logout macros
exten => s,1,Answer()
exten => s,2,AddQueueMember(${ARG1})
exten => s,3,Playback(agent-loginok)
exten => s,4,Hangup

exten => s,1,Answer()
exten => s,2,RemoveQueueMember(${ARG1})
exten => s,3,Playback(agent-loggedoff)
exten => s,4,Hangup

This is what I’m trying to do and what worked once:

inbound call -> queue -> erik’s phone -> park call (700) -> take call back (701)

After that the connection is there but there is no sound.

I tried stopping Asterisk and unloading and reloading ztdummy and zaptel, I updated the latest versions, I searched in the messages file for relevant lines and of course I googled and searched the internet.

If you have a suggestion, a pointer to what could be the solution or the solution itself please let me know. I will highly appreciate every effort and suggestion. If you need other info please let me know.

With a last attempt in the middle of the night it worked again a couple of times but no I’m back in trouble with connection but no sound