Retrieving ParkedCall is not working

Hello experts,

In Asterisk, we have:


parkext => *7
parkpos => 71-79

context => edvinapark
parkpos => 800-850
findslot => next


exten => _1XX,n,Set(CHANNEL(parkinglot)=parkinglot_edvina))
same => n,Set(__PARKINGLOT=parkinglot_edvina)
same => n,Dial(SIP/${EXTEN},60,ktwx)

When extension 101 calls extension 102, and when extension 102 presses *7 during the call, it parks the call in position 800.

When 102 dials 800 to retrieve the call, he gets the voice prompt that there is no call parked in this extension.

Here is the verbose:

-- Started music on hold, class 'default', on IAX2/101-3184

== Parked IAX2/101-3184 on 800 (lot parkinglot_edvina). Will timeout back to extension [102] 102, 8 in 45 seconds
– Added extension ‘800’ priority 1 to edvinapark (0x91e43c8)
– <SIP/102-0000006c> Playing ‘digits/8.ulaw’ (language ‘en’)
– <SIP/102-0000006c> Playing ‘digits/0.ulaw’ (language ‘en’)
– <SIP/102-0000006c> Playing ‘digits/0.ulaw’ (language ‘en’)
== Using SIP RTP CoS mark 5
– Executing [800@full:1] ParkedCall(“SIP/102-0000006d”, “800”) in new stack
– <SIP/102-0000006d> Playing ‘pbx-invalidpark.ulaw’ (language ‘en’)
– Channel SIP/102-0000006d tried to talk to nonexistent parked call 800
== Spawn extension (full, 800, 1) exited non-zero on ‘SIP/102-0000006d’

Is that a bug? Or did I make some mistake? I am having the same problem in an Asterisk 1.2.19 also.

Note that I am getting the same error prompt when calling this:

exten => 800,1,ParkedCall(800)

And when calling another park position which really doesn’t hold any parked call, I don’t get the error voice prompt, but I get (Extension not found) in CLI verbose.

I seem to remember there were a lot of problems with named lots, and you aren’t using the latest 1.6.2 version.

Also, I’d expect you would need to set PARKINGLOT when picking up the call.