Problem sending call from Asterisk to Alcatel using FXS

We have an Asterisk system directly connected to an Alcatel PBX. Our Asterisk system is using Digium TDM2400P card with FXS interface, while the Alcatel PBX is configured as FXO interface. Calls can be sent from Alcatel PBX to the Asterisk system perfectly. However, when we try to send calls from Asterisk to the Alcatel PBX, the Alcatel only answer the call occasionally. We tried to connect the FXS port to a telephone and the phone is ringing ok. We also tried to connect the FXS port to another FXO port from the same TDM2400P card, and the FXO port is also receiving the call perfectly. We tried to connect a CO line to the Alcatel and the Alcatel can answer the call with no problem!!

So, it looks like the problem is related to the interface between Asterisk and Alcatel. We tried to change the txgain settings in zapata.conf and turn on the boostringer option as well, but the problem persists. Does anybody have any clues on what the problem might be?

Thanks a lot.
Joseph Shi


My guess will be that polarity or ring cadence is at the heart of the problem. Also possibly Voltage. From memory the TDM ports are -24v the Alcatel would expect -48V


The problem is somehow fixed. If I tap the Alcatel FXO port with another phone set, Alcatel can always detect the incoming call and answer properly. I suspect it effectively increase the voltage/current flowing through the Alcatel FXO port. If anybody can give a detailed explanation, it would be great.


Tapping an extra phone (or whatever) only decreases voltage. Digium FXS with default Zaptel/North America seems to have lower voltage than a regular N. American PSTN line. You can try the method in feature request # 4542 to boost it.

But what the heck. If a phone makes it work, tap a resister to the port.