Problem install asterisk on Mandrake .... PLEASE HELP!


#1

Hello all!

I am trying to help a friend to install the Asterisk on the Mandrake, Linux remotely. I got mine running fine by using the AAH_1.5 because it one step installation from the CDs. I followed the instruction on this site: voip-info.org/wiki-Asterisk+ … stallation … the first few step seems very good. The installation part is seem to be ok. but I get trouble when I get to the CONFIGURATION part. this directory cd /var/lib/asterisk/keys does not exist. then I start to skip some part of the instruction and when I get to end of the installation guide, I tried to start the Asterisk …/usr/sbin/asterisk -vvvgc then the system telling me that the file is not exist. I went into the directory /usr/sbin/ and looking for the file …ASTERISK but did not see this file. I dont know why. during the compilation, maybe the files not not copy into this folder. But could you help me why it did not copy to this folder? … Any help would be appreciated…

thanks


#2

Not enough information to assist you directly. I would recommend getting a copy of or downloading this and following along:

voip-info.org/wiki/view/Aste … +Telephony


#3

MuppetMaster;

Thanks so much for this link to the instruction, but somehow the download site is not working any more. I tried this WGET and it did not work, maybe teh digium has change the files.

Anyway, at the site above, I can download just fine but it just did not compile for me correctly… wondering if you have any other way to download this file…?

Actaully… I am doing a remote install for my friend pc that has the mandrake installed on his server.

thanks


#4

What is the compilation error you are getting? Are you trying these download details:

asterisk.org/download

They seem to work.


#5

MuppetMaster;

thank you for your help and fast reply for my post. I have follow the instruction and download the ASTERISK-1.2.0 files and still did not get it work. I am just so tired right nowk, I will take some break and probably back to work on this again later tonight… but if you have any idea how to fix this, please let me know… it seems that everything compile right… but the directory … /usr/sbin/ … the file ASTERISK is not exist in this directory. as far as I have read, the file must be here to start the asterisk.

thanks…


#6

Did you do a ‘make install’ after compiling?


#7

MuppetMaster;

yes … I did run the make install, as state in the manual but seem it give me all kind of trouble. I just told my friend to reformat the drive and install everything from scratch and let start all over once more time…

thanks for helping…