Please People Help - Cisco 7940 + ZYCOO ZX20

Hello Every Body

Dear Brothers And Sisters Of This Community, Salute

i have bought an amazing Asterisk Based IP PBX (ZYCOO ZX20) its small in size portable and have modern design and i bought 6 of Cisco 7940 Phones with SIP firmware, But the problem is i don’t know how to configure the phones to communicate with the IP PBX because its my first time installing.

Due to my search on the web i know its possible to make them work together but i have no idea how, i am blank in this as of its my first time.

i have made some extensions on the ZYCOO ZX20 but i have no idea how to put the extension number, username and password on the Cisco 7940 Phone

Plz Guide Me I Need Your Help


ZYCOO ZX20 User Manual

Cisco 7940

Cisco 7940 User Manual

so no reply yet ?!?! :frowning:

Cisco 7900-series phones are a bear to configure and walking someone through the process is arduous. You’re going to be doing some Googling. Good luck.

Dear Sir Malcolmd

I did my goggling and sent messages for people who succeeded but no reply. and i had a document about the process of TFTP config File but my IP-PBX may not have this feature. but there must be a solution i didn’t join a huge community board to get a reply (do some goggling) so plz help.

But I Really Thank You For Passing By And At-least Reading My Problem.
what really makes me surprised that the whole Asterisk Community is watching and no one yet came up with a solution. i guess … or my problem may not worth to waste time on it to reply with a real solution.

Thank You Again

Dear Friends

I have managed to solve one of the problems, now the phones are registered on the IP PBX as SIP Extensions, and I can make a call to the PSTN line connected the FXO port.

My Plan Diagram

  1. Each extension with Cisco 7940 phones I made a call from the IP PBX Network to the PSTN Line to my mobile Phone and it works perfectly no problems at all.

  1. From The Cisco 7940 Phone I tried Making a call to the other Cisco 7940 Extension, The IP PBX replies that the extension Is Unavailable ?!?!?!

  1. I tried calling the the phone through the PSTN, The IP PBX always replies to the caller “that extension your are trying to reach is not available”.

  1. The Following Conditions Works

Now why is that happening ? does any of you have any idea about whats going on ?
whay cisco phones can make calls to outside world but dont communicat internally with other Cisco extension ? and why it can communicate internally with the CSIP app on the Smart Phones but not the opposite ?!

This appears to be a different problem

I don’t believe that any VoIP over Wifi system works perfectly. I would always expect voice quality and latency problems.

You haven’t provided nearly enough information to debug your problems. People who answer here are not going to spend more than one or two minutes on your problem, so need all the relevant configuration and suitably detailed logs, with the problems highlighted, to stand a chance.

Please Tell Me What Do you Require So I Will post all needed information so that you can help me.

The relevant parts of your configuration files and a log of sufficient verbosity (at least 3) that it clearly shows the progress of the call and diagnostics as to why it is failing.

i didn’t configure any file, i did that manually from the phone directly

  1. Settings -> Unlock Config
    Default Password : cisco

  2. SIP Configuration
    -> Line 1 Settings
    -> Name : 101
    -> Short Name : 101
    -> Authentication Name : 101
    -> Authentication Password : adgj100
    -> Display Name : Mohamed
    -> Proxy Address :
    -> Proxy Port : 5060
    -> Message URI : *97
    -> Preferred Codec : g711ulaw
    -> Out Of Band DTMF : avt
    -> Register with Proxy : No
    -> Register Expires : 3600
    -> TFTP Directory :
    -> Phone Label : Unprovisioned
    -> Enable VAD : No
    -> VoIP Control Port : 5060
    -> Start Media Port : 16384
    -> End Media Port : 32766
    -> Backup Proxy :
    -> Backup Proxy Port : 5060
    -> Emergency Proxy :
    -> Emergency Proxy Port : 5060
    -> Out bound Proxy :
    -> Out bound Proxy Port : 5060
    -> NAT Enabled : Yes
    -> NAT Address :
    -> Call Statistics : No

The IP PBX i am using has the IP address of
I don’t know what to do else

You’ve reached the point where I believe you need more hand holding than is reasonable for a peer support forum. You can request paid support on the Biz and Jobs forum.

no need for help, thank you so much

i solved the problem my self.

in the settings of the sip configuration

i had just to change
-> Register with Proxy : No
-> Register with Proxy : Yes

And it directly worked