Please help, issue with Wildcard


#1

hello all,

we have a dell poweredge 2850 with both TE410p and TDM2400P cards installed in it. i am having issues getting the system to load asterisk properly, and it comes down to the way the cards are loaded via the rc.local file.

when the server is rebooted, the following commands are run:

modprobe wct4xxp sleep 5 modprobe wctdm24xxp sleep 5 /sbin/ztcfg -vv sleep 5 /usr/sbin/safe_asterisk

however, asterisk will not load on it’s own - i get errors about channel 1 not existing and the zaptel subsystem does not load.

if i go back and rmmod both drivers and MANUALLY load everything, then i’m able to launch asterisk fine. in other words, the same set of commands run at startup do not work, whereas running them manually does work.

here is my zaptel.conf, i suppose this might have something to do with it.

span=1,1,0,esf,b8zs e&m=1-24 span=2,1,0,esf,b8zs e&m=25-48 span=3,1,0,esf,b8zs e&m=49-72 span=4,1,0,esf,b8zs fxsls=73-84 e&m=85-96 fxoks=97-120 loadzone=us defaultzone=us

we are using e&m wink signalling for our LD service (1-72 and 85-96) and kewlstart for the local (73-84) - yes, the fourth T1 is split, and yes the local come first. the wildcard is used to connect to our IVR (not asterisk based, yet) and is running on channels 97-120.

i’m stumped, and i’m getting sick of having to manually reboot and load the modules for this one server. if anyone has any thoughts, i’d love to hear them.

thanks,

Wes


#2

anyone?

another thought - do i need to reverse the order of the channels in zaptel.conf - put the 24 analog channels from the wildcard first, and have the quad span use channels 25-120?

don’t make me CALL digium…i hate being on the phone (yet i’m a telco admin - go figure).


#3

changed title in hopes of getting a response on this…


#4

Have you tried setting the sleep up say maybe 10? Another thing maybe take the usr/sbin/safe_asterisk out just to see if the cards will load at all before starting asterisk.


#5

yeah, i tried sleep 60 - modprobing the wildcard takes about 45 seconds or so to load, but even sleep 60 after the modprobe didn’t work.

if i don’t load asterisk automatically, and just attempt to start it from the command line, it fails. then, if i go back, rmmod everything, and manually modprobe the two cards, everything works fine.


#6

What Flavor of linux you running?


#7

fedora core 4, on a dell 2850.


#8

Couldnt find much on your problem except this wich was on FC 3 soory I couldnt help more

Timing is Critical re /dev/zap/ctl
by Anonymous on Tuesday 08 of February, 2005 [13:51:09]
I too hit the problem of /dev/zap/ctl not being available when I upgraded to FC3. It’s the udev stuff that creates devices on-the-fly. The problem is that when the zaptel module is loaded, it takes up to 5 seconds for the udev daemon to actually create the /dev/zap/ctl device. Unfortunately the startup script (/etc/init.d/zaptel) immediately runs the ztcfg command, before the device is ready.

Solutions: (1) manually run the “service zaptel reload” command after boot, as it just re-reuns the ztcfg command and by now the device is ready or (2) add a “sleep 5” command in your /etc/init.d/zaptel script just before ztcfg is run. Both fixed my problem.