PBX Keeping Line Open, How Can I Fix Remotely?

Asterisk version: 1.2.10, built from source
Hardware: Digium TDM13B (one FXS and three FXO)
Platform: Pentium 4 2.8 GHz, Fedora Core 5

In continuous operation with only one problem since January of 2006

It appears that the incoming line to the PBX has gotten stuck in the “off-hook” position (thus giving a continuous busy when called) and I need to know what if anything I can do about it from 1000 miles away.

I am able to access the PBX machine and gain root access. I tried saying “/etc/init.d/asterisk restart” and that didn’t work (Asterisk stopped and restarted without error but the phone line is still off hook).

What can I do to try to get the TDM13B card to release the line from 1000 miles away?

I’d like to try everything I possibly can before taking the absolute last resort of shutting down the PBX machine altogether and letting calls go to the backup answering machine. So, anything you all can suggest including “Hail Mary” attempts will be most welcome.

This is actually the second time this has happened in about a year and a half of operation, and the first time it happened, it was a blown FXO module; other than that, operation has been flawless and very impressive (heartfelt thanks to ALL who are responsible for this fine piece of software and equipment). I’m hoping against hope that it’s not another blown FXO module; obviously I can’t fix that remotely. :frowning:



have you tried rebooting the machine?

I would have though an init 6 would do the trick. or even relaoding zaptel may well do it.


Good morning, dswartz…

I have not tried that because I would like to exhaust every other less-invasive possibility first.

Asterisk tends not to start up particularly cleanly on this machine, for some reason I haven’t yet nailed down. It tends to give all kinds of error messages (which I don’t have here in front of me). I usually end up having to stop and restart it a few times and it then starts up cleanly and runs to perfection after that for months on end (last time I shut it down was about 6 months ago and that was only because we had a power failure and the UPS was getting low on battery power). I’m fairly skeptical of being able to do all of that from 1000 miles away over an ssh link. But, if all else fails I will try that.


Good morning, Ian.

“init 6” reboots the machine, right? … just like “shutdown -r now”, right? As I mentioned to dswartz I’m not quite ready to do that yet… want to exhaust other less-invasive options first because of the fact that asterisk tends not to start up cleanly from a reboot and I have to play with it for a little while (not sure I can do that from 1000 miles away).

As for reloading zaptel… Unfortunately I don’t have my notebooks here with me and so I’m going to have to ask some newbie-type questions that are well-documented in that notebook.

Is there more to reloading zaptel than just saying “rmmod zaptel” followed by “insmod zaptel” (or “modprobe zaptel”)?

I assume Asterisk needs to be shut down before I do that… is there anything I need to do besides “/etc/init.d/asterisk stop”?

So, if reloading zaptel is going to do the trick, is there anything I need to do besides the following sequence:

/etc/init.d/asterisk stop
rmmod zaptel
modprobe zaptel
/etc/init.d/asterisk start

[quote=“eric-nh”]So, if reloading zaptel is going to do the trick, is there anything I need to do besides the following sequence:

/etc/init.d/asterisk stop
rmmod zaptel
modprobe zaptel
/etc/init.d/asterisk start[/quote]

“lsmod” tells me that zaptel is used by wctdm, so I assume I also need to remove and reload wctdm, right? So, should the following sequence work?

/etc/init.d/asterisk stop
rmmod wctdm
rmmod zaptel
modprobe wctdm
/etc/init.d/asterisk start[/quote]

Maybe I need to “modprobe zaptel” before I “modprobe wctdm” but modprobe is supposed to find and load any other modules it needs, so “modprobe wctdm” should also pick up zaptel, right?