Paging/Intercom on Grandstream phones


What needs to be in the extensions.conf to get paging/intercom to work?
I am running *Now 1.0.2 with the new GUI and the GUI setup for paging did not work at all, just rings the extensions. I used the one below, and it beeps, but does not come out on the extension’s speaker at all.

I do have the phones setup to auto-answer depending on header, but it’s not happening.

Here’s the current setup in extensions.conf:


exten => _XXXX,1,Set(__SIPADDHEADER=Call-Info: Answer-After=0)

exten => _XXXX,n,Set(__SIP_URI_OPTIONS=intercom=true)

exten => _XXXX,n,Set(__ALERT_INFO=Ring Answer)

exten => _XXXX,n,Dial(SIP/${EXTEN},20|pN)


exten = s,1,SIPAddHeader(Alert-Info: ${PAGING_HEADER})

exten = s,n,Page(${ARG1}|${ARG2})

exten = s,n,Hangup


exten = _*1XXXX,1,Macro(pagingintercom|Local/${EXTEN:1…@ext-paging|d)


exten = 6400,1,Macro(pagingintercom|SIP/1…@ext-paging&SIP/1…@ext-paging|d)

Thanks for your help in advance if anyone knows! :smiley:

Find out from Grandstream what SIP header they require for auto answer. Also it could be a setting in the phone.

Grandstream says it should be “answer-after=0” and I have the phones configured for “Auto Answer by call info” = yes

I just cant figure it out.

Figured out this one too… :unamused:

Instead of:
LOCAL/ext# in the Paging statement it should be SIP/ext#

Paging works fine now…

Why would you want to use Local/ in this case ?

Hell if I know, AsteriskGUI put it in there in the first place!!!
That’s what caused the whole mess.

Then you may want to put in a bug report at

Thanks! Will do.