Old analog phone isn't ringing!


#1

Hello again!

Alright, I’m still in my testing phase and we tried multiple things… Now my problem is that in our test, we have an old phone… And by old, I mean OLD (but fonctional!). Now my problem is that when I call this phone, it doesn’t ring! I can pickup and talk to the other person, but the ringer doesn’t work! … And I know it’s fonctional because if you plug it into MaBell and call it, it rings… So it’s really something related to Asterisk and the Gateways…

I tried to pass the ,r option in Dial(), to force the ring, but with no result, still doesn’t ring…

I’m stuck at that point. Any of you has any ideas or hint about this one?


#2

Might be a stupid question but:

Is the phone DTMF? or rotary?

can you post the extensions.conf and sip.conf entries for the device?

also, run “sip show peers” in rasterisk to see if the phone adapter is authenticating and joining asterisk.


#3

It’s not stupid at all, I should’ve mentionned it! … It’s a DTMF phone, it’s old, but not THAT old!! :smile:

When I do a sip show peers in my CLI that’s what I get:
Name/username Host Dyn Nat ACL Port Status
5145550003/5145550003 192.168.0.5 D 5060 Unmonitored
5145550002/5145550002 192.168.0.5 D 5060 Unmonitored
5145550001/5145550001 192.168.0.5 D 5060 OK (26 ms)

Where 5145550003 is my old phone.

Here’s the entry for it in my sip.conf

[5145550003]
type=friend
user=5145550003
context=full
secret=5145550003
canreinvite=no
host=dynamic
realm=asterisk
dtmfmode=rfc2833
disallow=all
allow=g729
language=fr
mailbox=5145550003@default
callerid=“John Doe” <5145550003>

I have no specified entry for any of my other phones in my extensions.conf…

The fact that this phone dones’t ring… It’s really weird…I’m thinking that since it’s an old phone with a real ringer, my guess is that the voltage sent by asterisk is too low in order to make it ring… I just don’t know where to change that config…


#4

Your real phone is connected to a voip converter, which has its own power supply (so power to the ringer shouldnt be an issue.) The VOIP converter may be confused by the DTMF information and encoding information your sending it because its actually re-encoding the DTMF your real phone is sending into bits and bytes. try stripping out

dtmfmode=rfc2833
disallow=all
allow=g729
language=fr

Language setting shouldnt be critical as, if im correct, the Language setting simply determines in what language the asterisk server serves up the XML Pages to a voip phone (I.E. the interface text on the VOIP Phone.)

does the CLI for Asterisk give you any specific errors when the phone is connecting?


#5

By VOIP converter you talking about the Gateways right? That make sense, so the problem should resides somewhere in my gateway…

To be honest, it worked fine with another Gateway, so I know that’s probably related to it… But I figured that it can also be in asterisk. I mean if the other gateway ‘supported’ that, and the newer don’t, than maybe it’s a configuration in Asterisk.

Because I really need these in my sip.conf…
disallow=all
allow=g729
language=fr

disallow=all to make sure that I disable any other codecs that are called in my general context, then allow=g729 to only allow this particular codec (which is this one that I want to use), and finally, language-fr is very important since it play all the prompts in french to the user…

But only for the heck for it I tried without all these settings in my sip.conf and I got the same result.

No, that’s the thing. It goes like a normal call… in my CIL I see at the end:
SIP/5145550003-7069 is ringing

Than I pickup (even if it’s not ringing), and I got a conversation… like the calling, answering is fine, it’s only the ringer…


#6

It very well could be the ringer voltage supplied by your VoIP adapter is not compatible with your old phone. Those old phone were designed for a 90V ring signal coming from the phone comany. Most adapters do not provide a “true” ring signal since, to produce a true ring wave form requires a lot more voltage and amperage than can be supplied with a simple wall wart transformer. The manufacturers take shotcuts to create the ring signal like use a lower voltage or attempt to produce a stepped-sine wave.

Newer phone also have active ring detectors where the use opto isolators to detect the ring on the line and then provide a TTL signal into the rest of their circuitry that follows the ring pattern detected by the opto isolator. These type of ring detectors are a lot more flexible when it come to detecting and working with rings created by various consumer devices.

Mike


#7

wow…in which case the only thing i can think it might be is a gateway that doesnt like your analog phone :confused: as for the accepted protocol, its also usually something you can forcibly specify in your gateway as opposed to locking it in on sip.conf…


#8

Yeah that’s what I think too. Maybe I have to tell the gateway to send more voltage to the phones, if it’s possible (if the gateway supported it) But anyway, I got the gateway tech on the phone right now in order to resolve that issue… I’ll let you know how it worked out.

Thank you, and thank’s to you too nimbius!


#9

Have you plugged in a ‘newer’ phone into your gateway to test to make sure that it works? And if so…why are you spending all your time on this? Goto the 1$ store and buy a new phone maybe?


#10

Yeah, worked fine with other phones.

Because our market is old people. We can’t tell them to go buy a new phone! …


#11

THAT makes sense.
Hard to introduce change in that market.
I agree with SuperB’s opinion on the voltage. I can tell from experience, in the true sense, you can get a heck of a jolt from a phone line that has 'true 'ring voltage being applied.


#12

Not sure where you are located, but in the US, the older phones used different frequencies of ring voltage to differentiate people on a party line. (Remember party lines? Ha!) They also would wire the ringer from ‘tip’ to ground and from ‘ring’ to ground. (Tip and Ring and ground being the three wires in the phone cable). Almost all phone companies use a frequency in the middle now, somewhere around 33 HZ I think. The old phones had ringers set from 16hz to 66hz.

So, two things to check

  1. Take the phone apart and see if the ringer is:
    a. wired “across” tip and ring <-- this is good
    b. wired from tip OR ring to ground <-- change this

  2. Is the ringer marked with a frequency such as 16hz or 66hz
    a. if so, you’ll have to get a different ringer for the phone


#13

My ring problem is fixed since I’m now using the Mediatrix 1124 Gateway and I’m not having this problem no more…

But since we’re talking old phones here, just for testing purposes I swtiched one of my analog phone to pulse instead of tone. Has expected, it doesn’t work…

Does anyone knows if asterisk support theses kind of phone (pulse mode)?


#14

Wow thanks guys. I’ve been frustrating/wondering why I’m having the same problem, the exact same one with a Sipura 1001 ATA.

I hooked up a fax machine that works fine for ringing with the same model ATA and it rings fine as well…

time to upgrade to a more modern phone :smile: :blush: