No ZAP channel - x100P - redhat 9

I have been playing with asterix for a while now but I can’t seem to get my ZAP channel working. I am using a x100p knock-off (i know i know) and I believe I have configured it right:



channel => 1

ztcfg -vv
Zaptel Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)

1 channels configured.

zttool displays card as being OK. However, core show channels:
Channel Location State Application(Data)
0 active channels
0 active calls

What am I missing here?

Thanks for any guidence

You seem to say that you are using 1.4. Try make menuselect and scroll to chan_zap to see if you can compile it. You must load zaptel driver before compile.

When I load the menu it says:

XXX 16. chan_zap

Does that mean that I cant compile asterisk with it?

I did install the zapata drivers first, then made sure it was working via ztcfg -vv and then zttool.

I then compiled asterisk.

Any ideas on what I have to do next?

Thanks for any comments or help you might provide.



It turns out that the chan_zap is not being compiled with Asterisk. What the heck???

I am loading all the necessart modules before compiling (ztdummy first, then zapata, then wcfxo).

Any ideas???

Try run ./configure again when zaptel driver is on. Then recompile.

I did … I made sure that the drivers were loaded, then I ran make uninstall … after that I removed every asterisk folder from the system and decompressed the tar file again … after that I ran ./configure then make && make install … regardless of what I do the channel is not being recognized … help ???

I’m pretty sure you don’t need ztdummy if you use wcfxo. Try not loading it/remove it before reconfig/recompile.

Also you may want to make menuselect to see if it allows you to compile chan_zap and if not, why.

I am a bit confused … since the x100p is essentialy a modem, it doesnt have internal clocking and thats why I thought I would need the ztdummy loaded … are you sure I dont need ztdummy?

I thought an internal clock was all it had :astonished: Put it this way, ztdummy are never loaded on my machines running X100P.