No verbose in messages file

I’m running asterisk 13.6

Logger.conf is set to :

console => notice,warning,error,debug,verbose messages => notice,warning,error,verbose full => notice,warning,error,debug,verbose,dtmf,fax

a logger show channels gives:

/var/log/asterisk/full File Enabled - DEBUG NOTICE WARNING ERROR VERBOSE DTMF FAX /var/log/asterisk/messages File Enabled - NOTICE WARNING ERROR VERBOSE Console Enabled - DEBUG NOTICE WARNING ERROR VERBOSE

However, I do get my Verbose(1,this is my message) correctly output to the console, but notihng goes into /var/log/asterisk/messages or full (other data, like debug, notice, etc… do appear though)

I fail to understand why ! some help would be welcomed !


Run the following command and post the results

ps aux | grep asterisk

there is goes:

[code]root 365 11.4 0.9 4742960 320032 ? Ssl Dec10 134:36 asterisk
root 29798 0.0 0.0 12696 1768 pts/0 S+ 13:28 0:00 grep aster


Host is a debian 8.0, freshly installed, with asterisk 13.6.0 from the download page, compiled, with only additional app_mylql (havent had time yet to migrate to odbc).

I’ve actually installed 4 hosts recently, same issue on all of them

/////// Ok… found why, and it is a bit strange…

I’ve edited the default /etc/asterisk/asterisk.conf to uncomment the ;verbose=3 and now it does work with the level stated in the file (older version it would use the current level set through the console)

I guess I’ll have to toggle the level there !


Check if you can change verbosity level and enable debug from the cli, then see if these changes are passed on the log files (you will get bigger log files and debug messages also with verbose).

ok - I have verbose=1 in the config file, and I issued a core set verbose 3 on the cli (note that I connect via asterisk -rv usually)
The verbose greater than 1 do appear on the cli, but not in the log file, just the verbose(1,…) statements

connecting via asterisk -rvvv does not activate level 3 on the console nor in the file