Messages Log File

Hi All,
i have a asterisk 13.5 with a logging problem.

I have set logger.conf:

console => notice,warning,verbose,error,debug,dtmf
messages => notice,warning,verbose,error
error => error
debug => notice,warning,error,debug
verbose => notice,warning,error,verbose

and if i run logger show channels

Channel                             Type     Status    Configuration
-------                             ----     ------    -------------
/var/log/asterisk/verbose           File     Enabled    - NOTICE WARNING ERROR VERBOSE
/var/log/asterisk/debug             File     Enabled    - DEBUG NOTICE WARNING ERROR
/var/log/asterisk/error             File     Enabled    - ERROR
/var/log/asterisk/messages          File     Enabled    - NOTICE WARNING ERROR VERBOSE
                                    Console  Enabled    - DEBUG NOTICE WARNING ERROR VERBOSE DTMF

But when i check messages files on /var/log/asterisk there aren’t verbose info on it.

I see several post about it but didn’t find the soluction…
I’ve tried to enable verbose on asterisk.conf like he does but nothing change.

Some one could help me?
In this post said to run ps aux | grep asterisk, this is my output:

root@RCP-PBX:~# ps aux | grep asterisk
voncmgr   1459  1.3  0.9 3015724 77392 ?       Ssl  Jan12 123:11 asterisk
root     10915  0.0  0.0  11740   940 pts/0    S+   11:49   0:00 grep --color=auto asterisk


What verbosity is the console running at?

I believe that will be reflected in your log.

I’d try to change verbose= in /etc/asterisk/asterisk.conf, and possibly restart asterisk, see what it gives

I’ve verbose = 3 in asterisk.conf , i’ve tried to set on 10 but after module reload didn’t change anything.
I’ can’t restart asterisk right now i’ll try tonight.


It Works.