No /dev/dahdi

lspci reports 'ethernet controller: Doigium inc. TDM400P (rev 11)'
dahdi_hardware reports ‘Wildcard TDM410P’

However on booting and /etc/init.d/dahdi start:

'Loading hardware dahdi modules:
FATAL: Module dahdi not found.

wct4xxp: FATAL: Module wct4xxp not found [FAILED]

etc. etc. etc.

Error: Missing /dev/dahdi’

This is from initial install and when I had no hardware installed. I have since updated to 1.6 Asterisk. Downloaded kernel src, downloaded dahdi-linux- and dahdi-tools- Managed to compile and install with only errors reported being cannot delete zaptel directory.

I have tried manually creating /dev/dahdi devices but still fails and directory is removed on reboot.

Any ideas? Do I have to debug udev? Thanks.


You need to make sure that zaptel does not start up at boot.
So Asterisk uses DAHDI, and does not gets confused. Both zaptel and dahdi may be compiled and installed on the same system, both they may not be loaded at the same time.

You need to edit chan_dahdi.conf and run dahdi_cfg -vv to generate the files that are necessary… /dev/dahdi will be created.

This is my experience with zaptel and dahdi. Hope it works for you too.


There is as yet no chan_dahdi.conf. I have just this minute simply activated the template one. dahdi_cfg depends on /dev/ctl so cannot run. There should be no zaptel because I am running 1.6.

I have tried running dahdi_genconf to generate /etc/dahdi/system.conf (which dahdi_cfg uses) but the contents of this look inadequate…


So still stuck! Thanks


I have been in the same place where you are now.
In my case I had first installed the zaptel module + zapata drivers but I needed to update to DAHDI.
So I compiled dahdi but also I had no chan_dahdi.conf and other files. Also got the missing /dev/dahdi-message and so on.

I have documented my install, and in my case it helped to do the following :

  • make sure zaptel is not loaded (on CentOS : chkconfig 123456 zaptel off)
  • edit /etc/dahdi/modules (should be there if DAHDI has compiled without errors !) to make dahdi load the driver for your type of card.
  • restart

You should do a “dmesg | grep zaptel” to check if there are any traces of a zaptel module loading at bootup.
And a “dmesg | grep dahdi” to check if there were error-messages…

Give it a try.

Be sure that when compiling dahdi, there are no compile errors !

make install

chkconfig --list gives no zaptel listed.
dahdi set - off off on on on on off

/etc/dahdi/modules is present. Currently left as is. Had commented out all drivers except wctdm24xxp for TDM410P, for the card that is installed.

dmesg | grep zaptel - nothing
dmesg | grep dahdi - nothing

Spotted error in config.log in dahdi-tools,

ac_nonexistent.h: no such file …

/usr/bin/ld: cannot find -lusb

But none in any of the actual build or install runs logs any errors.

Tried 64 bit AsteriskNow. No Dahdi errors!
Am next trying updating this Asterisk 1.4 and then try switching to 1.6.

in my case, wctdm24xxp didn’t want to load. manual modprobe fixed problem.