New to Asterisk - Installation problems


#1

Hello,

I’m completely new to Asterisk and fairly new to Linux. After hearing so much about this free PBX, I couldn’t wait to get going so I’ve bought a PC especially for this purpose, installed Mandriva 2006 and am in the process of installing Asterisk itself.

I’ve downloaded the * book, all the softwate I need and have started configuring. Unfortunately, it all went fairly smoothly until I tried to install the Asterisk software. The book states that I would need a bunch of extra software in order to install Asterisk so I downloaded and installed all of them (GCC version 4.0.1, Bison, ncurses, OpenSSL). All of these went in ok using RPMs but as there is no RPM for *, tried the source route. Here’s where I ran into trouble. Initially, I got a few strange errors “Internal compiler error: segmentation fault”. After a couple more attempts at running the make command in succession (it seemed to get further after every attempt), I got to a point where the following error persisted and I can’t get any further with the installation (/usr/bin/ld: cannot find -lssd). I think this suggests that SSL is not present but I absolutely know it is because I installed it.

What have I done wrong? I don’t think I’ve missed any steps.

Any advice would be greatly appreciated.

Thanks,
Charles.


#2

did you install the -devel rpms for those packages ?


#3

I don’t think so. There was nothing in the filename that would have suggested so anyway. I downloaded the RPMs mostly from rpmfind.net and installed them using the built in installer application.


#4

maybe i should have been clearer … if you haven’t already, you need to install -devel papckages too.

from asteriskguru.com

[quote]* bison and bison-devel packages (This is used to build Asterisk)

  • ncurses and ncurses-devel packages (Used to build astman, etc.)
  • zlib and zlib-devel packages
  • openssl and openssl-devel packages[/quote]

#5

Unless you have a specific reason to use Mandriva 2006 for Asterisk, you can make your life much easier by installing Asterisk@home from an ISO image. Check it out here: asteriskathome.sourceforge.net/ It has everything needed, including the OS and administration tools and will run right away.
There is a very good documentation to go with Asterisk@Home.

There is even a vmware image you can read about here: serge.mankovski.com/voip/asteriskhome-25-vmware


#6

Hi folks,

It’s been a while since I’ve had enough time to work on my Asterisk on Mandriva 2006 project. As advised, I downloaded and installed each -devel package (used RPMs). Each package installed successfully but I’m still getting the same error as before (/usr/bin/ld: cannot find -lssl). I’m not sure what ro do next. RPMs seem to install fine but I can’t find one for Asterisk and Mandriva 2006. Any ideas?

BTW. I’m still considering the Asterisk@home option but since I’m using a wireless card in my box, I’m a bit hesitant about blowing away everything I’ve done so far and still not getting it to work because of the card.

Thanks again.
Charles.


#7

it still looks like you’re missing the OpenSSL libs. did they install cleanly ? can you locate them ?