New Asterisk User on FreeBSD


#1

I have installed Asterisk on a FreeBSD-6.0 server via ports and it went well. It appears to have installed all the dependencies and I want to give it a try. No real equipment like IP phones just yet but I wanted to at least set it up and see what can be done with just a simple analog phone and a regular BellSouth connection with a ComCast cable modem.

Ran into a few problems. I installed Asterisk-1.2.4 but it did not place the /etc/asterisk folder for me. So I unpacked the tarball and tried to do a make samples command but that crashed like this:

“Makefile”, line 28: Missing dependency operator
"Makefile", line 31: Need an operator
"Makefile", line 34: Need an operator
Error expanding embedded variable.

So I then tried a simple make but got the same thing.

Any advice out there on what I should try next?


#2

Found it. Should have read more of the posts first. It was gmake that’s needed not make. So that part is over…but

When I ran asterisk -vvvvc I got a bunch of stuff scrolling by and then at the very end these warnings…

[cdr_pgsql.so]May 23 11:57:22 WARNING[37964]: loader.c:325 __load_resource: Shared object “libpq.so.4” not found, required by "cdr_pgsql.so"
May 23 11:57:22 WARNING[37964]: loader.c:554 load_modules: Loading module cdr_pgsql.so failed!

Anyway, nothing appears to be running. Any advice would be appreciated.


#3

Okay…as usual Open Source is proving what I’ve always known. Great stuff, but unless you’re prepared to either pay for a professional to do it or you’re willing to drudge through days of reading docs, most of which won’t help anyway, you’ll never get it working. I first came across Asterisk on Monday around 12:00 PM. I installed it and reinstalled, rebuilt the entire OS, read docs until Midnight, posted questions in this forum as well as other newsgroups, experimented, almost gave up and then finally last night it worked. Well at least I got to the CLI prompt. I have yet to make or receive any calls. There is still something freaky about the mpg123 player. Haven’t figured that out yet. I also discovered that if you have PostgreSQL installed Asterisk will whack out on you…maybe. One machine did, the other didn’t. Can’t figure that one out…but I saw a post on this and it’s not exactly what I’d call a fix.

The docs are sketchy at best and mostly deal with Linux. I am running FreeBSD-6.1. The BSD port is broken out of the box so you either have to edit the Makefile to point to the new URL or update the ports first. Neither of which I knew much about…but I do now.

Trying to get a simple setup with no equipment is not much fun but until I get familiar with this and see that it will do what I need I can’t going blowing my $ on it. So I’m just trying to get familar with the command line and how to make some simple calls with no hardware purchases. The docs say I’m supposed to be able to do that but don’t kid yourself. This is not for the impatient or people used to M$ stuff which works out of the box.

I will keep trying but if anyone can offer some quick advice on what to do for VOIP without hardware…I have started toying with the Dialx software but I’m really looking for something that I can do to test the ability to send and receive some calls, place calls on hold, music on hold etc…caller id.


#4

Hello maxfiles,

how did you manage to get rid off the “Loading module cdr_pgsql.so failed” warnings?
The very same messages are printed in my “messages” log file.
Regards,

slowjoe


#5

I inserted the following line in “modules.conf”:

Now, asterisk keeps running, while it stopped after a couple of minutes before, printing the error message (warning) mentioned above.

@maxfiles: Did this do the trick for you, too?


#6

I did not resolve it so much as just found out why the error message was coming up.

If you installed Asterisk on FreeBSD using the ports then the install probably worked well (ie…you got all the dependencies and libraries installed too) but it does not install the files in the same directories as a Linux serever where Asterisk usually runs. Instead, the build adheres strictly to rules of the FreeBSD filesystem structure, which is a good thing, but comes with some caveats. You have to sometimes tell a program like Asterisk that the files it looks for are not in the usual places. And while this is usually done by editing some config files, it can also be overwhelming at times.

Needless to say, the PostgreSQL is similar. If you installed postgresl from the ports section it should probably be okay. But if, like I usually do, you installed PostgreSQL from source, then the files are not in the same location as if you installed them from the ports. Thus when the FreeBSD ports version of Asterisk is installed it looks for these files in a place where they are not. Thus the error messages.

Someone previously posted that I could mess with the Makefile, but I’m really not that good at coding. The method I chose was to uninstall pgsql and then install Asterisk from the ports.

All the docs say that Asterisk works well with pgsql, I just haven’t need the interface yet. I could try the method you referenced but that looks like it disables pgsql interface, even if only for that session.


#7

Thanks for your quick reply.
I installed Asterisk on my router (ASUS WL-500g Deluxe), which runs OpenWRT. Since storage and processing power on those devices is extremely limited, I did not install a DBMS like PostgreSQL.
I have to admit, that I do not know, what I did. It just works: Asterisk does not show any error messages or warnings anymore (even when started like ‘asterisk -vvvvvvdc’).
Now, I just wanted to confirm, that this was the correct action to perform…

Regards,

slowjoe