Asterisk 1.0.9 on FreeBSD 5.4


#1

I’m new to Asterisk and never tried to run it before. I’m trying to install version 1.0.9 on a FreeBSD 5.4
What I got is a list of warning end errors which finish like that:
“Makefile”, line 254: Missing dependency operator
"Makefile", line 255: Could not find .depend
"Makefile", line 256: Need an operator
"Makefile", line 282: Missing dependency operator
"Makefile", line 285: Need an operator
"Makefile", line 287: warning: duplicate script for target “build.h” ignored
"Makefile", line 288: Need an operator
make: fatal errors encountered – cannot continue

Did anybody tried to install * on FreeBSD and ancountered similar problem? Or maybe there is mistake on my side. All help will be appreciated.

Regards,
Pawel


#2

Try using “gmake”


#3

Tried this myself but got the following and plenty of errors prior to this:

zaptel.c:2582: warning: 'zt_release' defined but not used zaptel.c:2681: warning: 'zt_timer_ioctl' defined but not used zaptel.c:2730: warning: 'zt_common_ioctl' defined but not used zaptel.c:2989: warning: 'recalc_slaves' defined but not used zaptel.c:3019: warning: 'zt_ctl_ioctl' defined but not used gmake: *** [zaptel.o] Error 1 usr/local/src/zaptel

Any other ideas?

Regards,
Brian


#4

To install Asterisk, you need:

  1. Go to FreeBSD.org site look for ported application, asterisk.
  2. Download the asterisk.tar.gz file and extract to /usr/ports
  3. Modified /usr/ports/net/asterisk/MakeFile and point the master to
    ftp://ftp.digium.com/pub/asterisk
    ftp://ftp.digium.com/pub/old-releases
  4. If you have downloaded asterisk-1.0.9.tar.gz put in /usr/ports/distfiles
  5. Run make install in /usr/ports/net/asterisk

Happy Compiling!


#5

Just wanted to say that I installed Asterisk 1.0.9 from ports on a fresh insall of FreeBSD 5.4 without any major issues.

Had to patch the Zaptel drivers to work with my FXS module, but I can now use a normal T200 desk phone.

Now comes all the fun of creating and tweaking a dial plan…