Install Asterisk 1.2.1 on FreeBSD 5.4 make fail

I want to install Astrisk 1.2.1 on my FreeBSD system but make fails.

khif01# make
"Makefile", line 28: Missing dependency operator
"Makefile", line 31: Need an operator
"Makefile", line 34: Need an operator
Error expanding embedded variable.

What to do? Am I missing something here?



I am new at asterisk so have never tried to build it on BSD (my normal platform), but this sort of error looks like one that happens when you try and build software that requires gnu make. So install gnu make (gmake) and try it with that.


The above post is absolutely right.
and gmake install
and asterisk will install without any problem

Thank you guys . I thought i might of grabed a bunk copy after make didnt work. ./configure worked so i knew something was wrong with my brain. For some reason i keep forgetting about gmake

Thank you once again

ryry :smiley:

This is a older version don’t you think?

Update your ports collection, (cvsup? portsnap?)

You could install another shell (bash for example), and use gmake.


edit : my install was 1.4.0 on OpenBSD4.0
but gmake still did the job