Need help calling out with AsteriskNow 1.4.0 B2

Ok. I’ve been working on this almost 3 days straight. I’m very experienced with Windows but have very little linux experience. I’ve had a crash course the last 3 days and it’s been quite a ride. I think I’m really close to getting 90% of this thing working but I need help with outgoing calls.

I initially tried to get this setup through the http GUI but found it wasn’t working and there wasn’t enough help to go by. So I figured out how to get in there and manually edit files. I have literally viewed hundreds of pages over the last few days looking for answers on X-Lite, Asterisk, Broadvoice, and other topics and have found quite a few that are helpful. Unfortunately, I’m stuck on a particular issue and can’t go any farther on my own.

I can call from my cell phone to my asterisk number and it rings directly to the X-Lite (3.0) on my computer (ext 601) and I can answer [UPDATE: NOW RINGING TO ANALOG PHONE ON SIPURA 2100]. After answering, I can here and talk from both sides. So other than setting up incoming rules to auto attendant, etc, incoming appears to work fine.

I’m having trouble calling out though. I try to dial using various combinations (with and without leading 9) of 1, the area code, and the number. In ALL cases when I try to dial out, I get a busy from Asterisk since it can’t connect. I can call internally from ext 601 to 602 without a problem…

Here’s my physical setup:
[OFFICE] (Asterisk) -> (NAT SonicWall) -> (WWW) <- (NAT Netgear) <- (PC / X-Lite) [HOME]

Software (parts I think are relevant. I can include whole thing if needed):

I removed most of this post since this has been totally changed several times and I am no longer worrying about the Xlite phone…

few suggestions- 1. do NOT use spaces in extensions.conf

exten => something, 1, application(arguments)
exten => something,1,application(arguments)

the only place there should be spaces is before and after the =>

second, make yourself an outgoing context and put your xlite phone in it.

see if that helps

Update: I am no longer worrying about the Xlite connection. I’ve got an analog phone connected via a Sipura 2100 to the Asterisk server. So I’m having trouble dialing with the Sipura, Xlite, and any other way I could imagine.

I know there’s a bunch of junk in here from the GUI. I tried to set it up via the GUI and it wouldn’t connect, so I abandoned it for the manual way again. There are also other inbound numbers and one other extension, but I don’t believe those are relevant for this particular issue the way I understand it…

Ok. I thought by setting the “context” of [601] in users.conf to “outgoing-1”, it should try to dial out from the extension. However, it always tells me that it can’t find the number I dial in the correct context. “Looking for 9390[last 4 digits] in outgoing-1 (domain”

I tried removing spaces in outgoing context but no matter what else, I try, I can’t get the outgoing calls to go through. Now what???

; -----------------------------------------------------------
; -----------------------------------------------------------
provider =
trunkstyle = customvoip
username =
authname = 478287xxxx
trunkname = Custom - Broadvoice 478287xxxx (ATL) DO NOT EDIT VIA WEB
callerid =
hasexten = no
hassip = yes
hasiax = no
registeriax = no
registersip = no
host =
dialformat = ${EXTEN:1}
context = DID_trunk_1 ; default
group =
insecure = very
fromuser = 478287xxxx
fromdomain =
qualify = yes
pedantic = no

fullname = My Name (Office Sipura)
secret = xxxxx
email =
cid_number = 478287xxxx
zapchan =
context = outgoing-1
hasvoicemail = yes
hasdirectory = no
hassip = yes
hasiax = no
hasmanager = no
callwaiting = yes
threewaycalling = yes
mailbox = 601
hasagent = no
group =
host = dynamic
nat = no

; -----------------------------------------------------------
; -----------------------------------------------------------
exten => 8500,1,VoicemailMain
exten => 8500,n,Hangup
include => voicemenu-custom-1
exten => 600,1,Goto(voicemenu-custom-1|s|1)

comment = mainmenu
exten = s,1,Answer
exten = s,2,Background(thank-you-for-calling)
exten = s,3,Background(if-u-know-ext-dial)
exten = s,4,Background(otherwise)
exten = s,5,Background(pls-hold-while-try)
exten = s,6,Background(to-reach-operator)
include = default
alias_exten = 600

plancomment = DialPlan1
include = default
exten = _91700XXXXXXX.,1,Macro(trunkdial,${}/${EXTEN:1})
comment = _91700XXXXXXX.,1,IAXTEL,standard
exten = _9256XXXXXXX.,1,Macro(trunkdial,${}/${EXTEN:4})
comment = _9256XXXXXXX.,1,Local,standard
exten = _9011XXXXXXX.,1,Macro(trunkdial,${}/${EXTEN:1})
comment = _9011XXXXXXX.,1,International,standard
exten = _911.,1,Macro(trunkdial,${trunk_1}/${EXTEN:0})
comment = _911.,1,911,standard
exten = _9XXXXXXX.,1,Macro(trunkdial,${trunk_1}/${EXTEN:1})
exten = _91XXXXXXXXXX.,1,Macro(trunkdial,${trunk_1}/${EXTEN:1})
comment = _91XXXXXXXXXX.,1,Longdistance,standard

exten => _91NXXNXXXXXX,1,Dial(SIP/${EXTEN:1}@trunk_1,30,r)
exten => _9NXXNXXXXXX,2,Dial(SIP/${EXTEN:1}@trunk_1,30,r)
exten => _9NXXXXXX,3,Dial(SIP/${EXTEN:1}@trunk_1,30,r)
exten => _1NXXNXXXXXX,4,Dial(SIP/${EXTEN}@trunk_1,30,r)
exten => _NXXNXXXXXX,5,Dial(SIP/${EXTEN}@trunk_1,30,r)
exten => _NXXXXXX,6,Dial(SIP/${EXTEN}@trunk_1,30,r)

exten = executecommand,1,System(${command})
exten = executecommand,n,Hangup()
exten = record_vmenu,1,Answer
exten = record_vmenu,n,Playback(vm-intro)
exten = record_vmenu,n,Record(${var1})
exten = record_vmenu,n,Playback(vm-saved)
exten = record_vmenu,n,Playback(vm-goodbye)
exten = record_vmenu,n,Hangup
exten = play_file,1,Answer
exten = play_file,n,Playback(${var1})
exten = play_file,n,Hangup
hasbeensetup = N

include = default
;exten = _X.,1,Goto(default|600|1)
exten => 478287xxxx,1,Goto(default|600|1)

include = default
;exten = _X.,1,Goto(default|600|1)
exten => 478287yyyy,3,Goto(default|600|1)

include = default
;exten = _X.,1,Goto(default|600|1)
exten => 404795zzzz,1,Goto(default|600|1)

; -----------------------------------------------------------
; -----------------------------------------------------------
— (16 headers 20 lines) —
Sending to : 5060 (no NAT)
Using INVITE request as basis request - e2ff6526-3415ed48@
Found peer ‘601’
Found description format PCMU for ID 0
Found description format G726-32 for ID 2
Found description format G723 for ID 4
Found description format PCMA for ID 8
Found description format G729a for ID 18
Found description format G726-40 for ID 96
Found description format G726-24 for ID 97
Found description format G726-16 for ID 98
Found description format NSE for ID 100
Found description format telephone-event for ID 101
Capabilities: us - 0x8000e (gsm|ulaw|alaw|h263), peer - audio=0xd0d (g723|ulaw|alaw|g726|g729|ilbc)/video=0x0 (nothing), combined - 0xc (ulaw|alaw)
Non-codec capabilities (dtmf): us - 0x1 (telephone-event), peer - 0x1 (telephone-event), combined - 0x1 (telephone-event)
Peer audio RTP is at port
Looking for 9390[last 4 digits] in outgoing-1 (domain

<— Reliably Transmitting (no NAT) to —>
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP;branch=z9hG4bK-abd7d49c;received=
From: My Name (Sipura 1L2) sip:601@;tag=cb7b338effd23200o1
To: <sip:9390[last 4 digits]@>;tag=as42b5e7f8
Call-ID: e2ff6526-3415ed48@
CSeq: 102 INVITE
User-Agent: Asterisk PBX
Supported: replaces
Content-Length: 0

Ok, figured out I needed some changes to the outgoing dial plan and had to include the [outgoing] in [default]. Now I’ve got other issues. Moved to new thread: