Newbie - Extension Problems


#1

I have a strange knack for getting involved with things entirely out of my depth and asterisk has been one of them. I was excited when i hooked it up and got connected from my pc with Xten, then it all went horribly wrong.

I have an old pIII 450mhz with 128mb and 10/100 ethernet card, i have installed astersik@home and all tickedy boo.

I have created 3 extensions. 200, 201, 202. 200 = Desktop (xten), 201 = My Pocket PC SJPhone (WiFi), 202 = Computer Downstairs (Xten). All report to me they are logged in and their status is reported in the panel when i dial a call i.e. it says i am busy.

If i dial the usuall asterisk test numbers like *xx from all extensions it works fine, so i guess i have a good connection, but when i try to call any extension i get “the person at extension xxx is on the phone, please try later” when i know i am not on the phone. This message is obviously generated by the server so i am logged in fine. If i leave a voicemail i can pick it up the normal way from the extension i just called.

The server goes into a 4 port router ( i simply use this as a switch, not for internet purposes) i have no NAT or anything installed. But i forwarded all traffic 5060 to the asterisk box, still no joy.

I am really gutted that i cant even make or receive internal calls, as all i want to do after that is hook up my phone line into the back and start receiving calls. Im not even bothered about voip. Someone please help a poor distressed soul :frowning:


#2

You could first ensure that DND is off by dialing *79.

From there, I would recommend getting familiar with the CLI. From your Asterisk@Home console, type “asterisk -rvv” to connect with your running Asterisk system. More 'v’s = more verbosity on the output you’ll see. With the CLI, you’ll also learn a lot more about how Asterisk operates as well.

Happy learning and good luck.


#3

now a stroke of luck, my pc downstairs can receive calls from any handset and make calls.

I have tried running in verbose mode but it all scrolls too fast, how do i scroll back trhough the log to see what is going wrong. I can see something like extension 200 = Busy but then it flies past

Thanks for your help


#4

thank you so much, i am a total dumbass. I had do not disturb on all the time. what a wally.

Thank you all so much for your time.

No doubt i’ll be back on here again